summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-14 07:05:38 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-04-14 07:05:38 +0700
commit1829132667d12132edc9f2f0bf8457bb29be0e7f (patch)
tree0dbe90459110887f72a919cd0e720fc74fb0c87b
parentc2ad18d313d10c51bcb822c048d56aa7c7c0530d (diff)
downloadslackbuilds-1829132667d12132edc9f2f0bf8457bb29be0e7f.tar.gz
slackbuilds-1829132667d12132edc9f2f0bf8457bb29be0e7f.tar.xz
audio/lyvi: Added (A simple command-line lyrics viewer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/lyvi/README9
-rw-r--r--audio/lyvi/lyvi.SlackBuild92
-rw-r--r--audio/lyvi/lyvi.info10
-rw-r--r--audio/lyvi/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/audio/lyvi/README b/audio/lyvi/README
new file mode 100644
index 0000000000..be55afabfc
--- /dev/null
+++ b/audio/lyvi/README
@@ -0,0 +1,9 @@
+lyvi (A simple command-line lyrics viewer)
+
+Command-line lyrics (and more!) viewer.
+
+NOTE:
+
+this require 'psutil' and 'plyr' with PYTHON3 bindings.
+
+Optional deps: pygobject3-python3 and dbus-python3
diff --git a/audio/lyvi/lyvi.SlackBuild b/audio/lyvi/lyvi.SlackBuild
new file mode 100644
index 0000000000..13eb9b533d
--- /dev/null
+++ b/audio/lyvi/lyvi.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+#
+# Slackware build script for lyvi.
+#
+# Copyright 2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=lyvi
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# remove pip dependency.
+sed -e '/require/d' --in-place setup.py || die
+
+python3 setup.py install --root=$PKG --optimize=1
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr/man; rm -rf $PKG/usr/share
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp LICENSE.txt pip_requirements.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/lyvi/lyvi.info b/audio/lyvi/lyvi.info
new file mode 100644
index 0000000000..27293758c2
--- /dev/null
+++ b/audio/lyvi/lyvi.info
@@ -0,0 +1,10 @@
+PRGNAM="lyvi"
+VERSION="2.0.0"
+HOMEPAGE="http://ok100.github.io/lyvi"
+DOWNLOAD="https://github.com/ok100/lyvi/archive/v2.0.0/lyvi-2.0.0.tar.gz"
+MD5SUM="8c85fc43b8f7f225fd4231801762a6bb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-urwid python3-pillow python3-Cython psutil plyr"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/audio/lyvi/slack-desc b/audio/lyvi/slack-desc
new file mode 100644
index 0000000000..fbd2002157
--- /dev/null
+++ b/audio/lyvi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lyvi: lyvi (A simple command-line lyrics viewer)
+lyvi:
+lyvi: Command-line lyrics (and more!) viewer.
+lyvi:
+lyvi: Homepage: http://ok100.github.io/lyvi
+lyvi:
+lyvi:
+lyvi:
+lyvi:
+lyvi:
+lyvi: