summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Zhu Qun-Ying <zhu.qunying@gmail.com>2018-09-05 00:39:54 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-09-08 08:37:40 +0700
commit22245dbe4ea84060263397cfb41e64f4f05f842a (patch)
tree3d35b8a23ba870ae6610f1cec04bbc99ab39ed3f
parentc78374d3e6008e734b6b7e8b62d6da0c90cceef3 (diff)
downloadslackbuilds-22245dbe4ea84060263397cfb41e64f4f05f842a.tar.gz
slackbuilds-22245dbe4ea84060263397cfb41e64f4f05f842a.tar.xz
system/hh: Removed (please use system/hstr).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/hh/README6
-rw-r--r--system/hh/hh.SlackBuild109
-rw-r--r--system/hh/hh.info10
-rw-r--r--system/hh/slack-desc19
4 files changed, 0 insertions, 144 deletions
diff --git a/system/hh/README b/system/hh/README
deleted file mode 100644
index 7a0586e4fd..0000000000
--- a/system/hh/README
+++ /dev/null
@@ -1,6 +0,0 @@
-Bash and Zsh shell history suggest box - easily view, navigate, search and
-manage your command history.
-
-It is a command line utility which brings improved command completion from
-the history. It aims to make completion easier to use and more efficient
- than Ctrl-r.
diff --git a/system/hh/hh.SlackBuild b/system/hh/hh.SlackBuild
deleted file mode 100644
index 1a500ef749..0000000000
--- a/system/hh/hh.SlackBuild
+++ /dev/null
@@ -1,109 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for hh
-
-# Copyright 2014-2015 Zhu Qun-Ying
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=hh
-VERSION=${VERSION:-1.25}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGNAM=hstr
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PKGNAM
-tar xvf $CWD/$PRGNAM-$VERSION-src.tgz
-cd $PKGNAM
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-ac_cv_func_malloc_0_nonnull=yes \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Save this from next Slackware release
-#sed -i 's/lncursesw/lncursesw -ltinfo/g' src/Makefile
-
-make
-make install DESTDIR=$PKG
-
-ln -sf hh $PKG/usr/bin/hstr
-ln -sf hh.1 $PKG/usr/man/man1/hstr.1
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/hh/hh.info b/system/hh/hh.info
deleted file mode 100644
index fcc798df5c..0000000000
--- a/system/hh/hh.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="hh"
-VERSION="1.25"
-HOMEPAGE="https://github.com/dvorka/hstr"
-DOWNLOAD="https://github.com/dvorka/hstr/releases/download/1.25/hh-1.25-src.tgz"
-MD5SUM="5d5f384fdc3819900456eb302e6ddef1"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Zhu Qun-Ying"
-EMAIL="zhu.qunying@gmail.com"
diff --git a/system/hh/slack-desc b/system/hh/slack-desc
deleted file mode 100644
index 29a7bd1aa6..0000000000
--- a/system/hh/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-hh: hh (BASH and Zsh Shell History Suggest Box)
-hh:
-hh: BASH and Zsh Shell history suggest box is a command line utility that
-hh: brings improved command completion from the history. It aims to
-hh: make completion easier and more efficient than Ctrl-r.
-hh:
-hh:
-hh:
-hh:
-hh: homepage: https://github.com/dvorka/hstr
-hh: