summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dugan Chen <thedoogster [at] gmail [dot] com>2018-08-09 21:32:39 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-11 07:23:09 +0700
commit22db108cd5ae8449ef0e65e657820addfac0d110 (patch)
tree3d62fc6f81f5c7b9346d3dd2cd6d42276a928948
parent66f7f0aa09e3ea2b5b2159d7b4b474d384882905 (diff)
downloadslackbuilds-22db108cd5ae8449ef0e65e657820addfac0d110.tar.gz
slackbuilds-22db108cd5ae8449ef0e65e657820addfac0d110.tar.xz
libraries/DevIL: Updated for version 1.8.0.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--libraries/DevIL/04_png_set_expand_gray.diff26
-rw-r--r--libraries/DevIL/DevIL.SlackBuild56
-rw-r--r--libraries/DevIL/DevIL.info6
-rw-r--r--libraries/DevIL/README20
-rw-r--r--libraries/DevIL/lib64.diff90
-rw-r--r--libraries/DevIL/patch-include_IL_il.h13
6 files changed, 125 insertions, 86 deletions
diff --git a/libraries/DevIL/04_png_set_expand_gray.diff b/libraries/DevIL/04_png_set_expand_gray.diff
deleted file mode 100644
index 78fe892881..0000000000
--- a/libraries/DevIL/04_png_set_expand_gray.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: devil-1.7.8/src-IL/src/il_icon.c
-===================================================================
---- devil-1.7.8.orig/src-IL/src/il_icon.c 2013-05-21 00:08:36.847356129 +0200
-+++ devil-1.7.8/src-IL/src/il_icon.c 2013-05-21 00:10:29.317942183 +0200
-@@ -525,7 +525,7 @@
-
- // Expand low-bit-depth grayscale images to 8 bits
- if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
-- png_set_gray_1_2_4_to_8(ico_png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
- }
-
- // Expand RGB images with transparency to full alpha channels
-Index: devil-1.7.8/src-IL/src/il_png.c
-===================================================================
---- devil-1.7.8.orig/src-IL/src/il_png.c 2009-03-08 08:10:09.000000000 +0100
-+++ devil-1.7.8/src-IL/src/il_png.c 2013-05-21 00:10:18.554077504 +0200
-@@ -278,7 +278,7 @@
-
- // Expand low-bit-depth grayscale images to 8 bits
- if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
-- png_set_gray_1_2_4_to_8(png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- }
-
- // Expand RGB images with transparency to full alpha channels
diff --git a/libraries/DevIL/DevIL.SlackBuild b/libraries/DevIL/DevIL.SlackBuild
index 3cf47dc1ea..c01bc4a74c 100644
--- a/libraries/DevIL/DevIL.SlackBuild
+++ b/libraries/DevIL/DevIL.SlackBuild
@@ -6,14 +6,13 @@
# Currently maintained by Dugan Chen
PRGNAM=DevIL
-SRCNAM=devil
-VERSION=${VERSION:-1.7.8}
+VERSION=${VERSION:-1.8.0}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -24,8 +23,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -43,9 +42,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM-$VERSION
+rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
+cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -53,39 +52,28 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix build with gcc5
-patch -p0 < $CWD/patch-include_IL_il.h
-
-# Build against libpng14, not libpng12.
-sed -i 's/png12/png14/g' configure
-
-# Fix further linking issues with libpng. This patch is taken
-# from Ubuntu. Without this patch, DevIL will compile, but attempts
-# to link against it will break.
-patch -p1 < $CWD/04_png_set_expand_gray.diff
+if [ "$LIBDIRSUFFIX" = "64" ]; then
+ patch -p1 < $CWD/lib64.diff
+fi
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --datarootdir=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --enable-static=no \
- --enable-ILU=yes \
- --enable-ILUT=yes \
- --build=$ARCH-slackware-linux
-make
-make install DESTDIR=$PKG
+mkdir -p DevIL/build
+cd DevIL/build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ../..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-rm -f $PKG/usr/info/dir
-gzip -9 $PKG/usr/info/*.info*
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING CREDITS ChangeLog INSTALL Libraries.txt \
- NEWS README README.unix TODO examples/ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md DevIL-docs/ DevIL/CREDITS DevIL/INSTALL DevIL/NEWS \
+ DevIL/Libraries.txt DevIL/README.cmake \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/DevIL/DevIL.info b/libraries/DevIL/DevIL.info
index 073e932c59..a54fdb0627 100644
--- a/libraries/DevIL/DevIL.info
+++ b/libraries/DevIL/DevIL.info
@@ -1,8 +1,8 @@
PRGNAM="DevIL"
-VERSION="1.7.8"
+VERSION="1.8.0"
HOMEPAGE="http://openil.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/project/openil/DevIL/1.7.8/DevIL-1.7.8.tar.gz"
-MD5SUM="7918f215524589435e5ec2e8736d5e1d"
+DOWNLOAD="http://downloads.sourceforge.net/project/openil/DevIL/1.8.0/DevIL-1.8.0.tar.gz"
+MD5SUM="4d8c21aa4822ac86d77e44f8d7c9becd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/DevIL/README b/libraries/DevIL/README
index 5cf9e09ca9..95f527de91 100644
--- a/libraries/DevIL/README
+++ b/libraries/DevIL/README
@@ -1,16 +1,16 @@
-Developer's Image Library (DevIL), formerly called OpenIL, is a programmer's
-library to develop applications with very powerful image loading capabilities,
-yet is easy for a developer to learn and use. Ultimate control of images is
-left to the developer, so unnecessary conversions, etc. are not performed.
-DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert,
+Developer's Image Library (DevIL), formerly called OpenIL, is a programmer's
+library to develop applications with very powerful image loading capabilities,
+yet is easy for a developer to learn and use. Ultimate control of images is
+left to the developer, so unnecessary conversions, etc. are not performed.
+DevIL utilizes a simple, yet powerful, syntax. DevIL can load, save, convert,
manipulate, filter and display a wide variety of image formats.
-Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm,
-.mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw,
+Currently, DevIL can load .bmp, .cut, .dds, .doom, .gif, .ico, .jpg, .lbm,
+.mdl, .mng, .pal, .pbm, .pcd, .pcx, .pgm, .pic, .png, .ppm, .psd, .psp, .raw,
.sgi, .tga and .tif .hdr files.
-Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx,
+Formats supported for saving include .bmp, .dds, .h, .jpg, .pal, .pbm, .pcx,
.hdr, .pgm,.png, .ppm, .raw, .sgi, .tga and .tif.
-DevIL currently supports the following APIs for display: OpenGL, Windows GDI,
-SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include
+DevIL currently supports the following APIs for display: OpenGL, Windows GDI,
+SDL, DirectX and Allegro. Compilers that can compile DevIL or use it include
Djgpp, MSVC++, Linux gcc, Delphi, Visual Basic, Power Basic and Dev-C++.
diff --git a/libraries/DevIL/lib64.diff b/libraries/DevIL/lib64.diff
new file mode 100644
index 0000000000..4ce91b34a6
--- /dev/null
+++ b/libraries/DevIL/lib64.diff
@@ -0,0 +1,90 @@
+diff -rupN DevIL.orig/DevIL/src-IL/CMakeLists.txt DevIL/DevIL/src-IL/CMakeLists.txt
+--- DevIL.orig/DevIL/src-IL/CMakeLists.txt 2017-01-01 16:03:56.000000000 -0800
++++ DevIL/DevIL/src-IL/CMakeLists.txt 2018-08-08 20:18:42.144194766 -0700
+@@ -147,7 +147,7 @@ else(LIBSQUISH_FOUND)
+ endif(LIBSQUISH_FOUND)
+
+ # Sets the output folders
+-set(LIBDIR "../lib/")
++set(LIBDIR "../lib64/")
+ set(LIBDIR "${LIBDIR}${EX_PLATFORM_NAME}")
+ if(UNICODE)
+ set(LIBDIR "${LIBDIR}/unicode")
+@@ -248,14 +248,14 @@ configure_file( pkgconfig/IL.pc.cmake.in
+
+ # Installation
+ install (TARGETS IL
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib64
++ LIBRARY DESTINATION lib64
+ RUNTIME DESTINATION bin
+ )
+ install (FILES ../include/IL/il.h DESTINATION include/IL)
+
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/IL.pc
+- DESTINATION lib/pkgconfig
++ DESTINATION lib64/pkgconfig
+ )
+
+diff -rupN DevIL.orig/DevIL/src-ILU/CMakeLists.txt DevIL/DevIL/src-ILU/CMakeLists.txt
+--- DevIL.orig/DevIL/src-ILU/CMakeLists.txt 2017-01-01 16:03:56.000000000 -0800
++++ DevIL/DevIL/src-ILU/CMakeLists.txt 2018-08-08 20:18:20.040193100 -0700
+@@ -58,7 +58,7 @@ configure_file( pkgconfig/ILU.pc.cmake.i
+ ${CMAKE_CURRENT_BINARY_DIR}/ILU.pc @ONLY)
+
+ # Sets the output folders
+-set(LIBDIR "../lib/")
++set(LIBDIR "../lib64/")
+ set(LIBDIR "${LIBDIR}${EX_PLATFORM_NAME}")
+ if(UNICODE)
+ set(LIBDIR "${LIBDIR}/unicode")
+@@ -74,14 +74,14 @@ endif(UNICODE)
+
+ # Installation
+ install (TARGETS ILU
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib64
++ LIBRARY DESTINATION lib64
+ RUNTIME DESTINATION bin
+ )
+ install (FILES ../include/IL/ilu.h DESTINATION include/IL)
+
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/ILU.pc
+- DESTINATION lib/pkgconfig
++ DESTINATION lib64/pkgconfig
+ )
+
+diff -rupN DevIL.orig/DevIL/src-ILUT/CMakeLists.txt DevIL/DevIL/src-ILUT/CMakeLists.txt
+--- DevIL.orig/DevIL/src-ILUT/CMakeLists.txt 2017-01-01 16:03:56.000000000 -0800
++++ DevIL/DevIL/src-ILUT/CMakeLists.txt 2018-08-08 20:18:32.104194009 -0700
+@@ -56,7 +56,7 @@ configure_file( pkgconfig/ILUT.pc.cmake.
+ ${CMAKE_CURRENT_BINARY_DIR}/ILUT.pc @ONLY)
+
+ # Sets the output folders
+-set(LIBDIR "../lib/")
++set(LIBDIR "../lib64/")
+ set(LIBDIR "${LIBDIR}${EX_PLATFORM_NAME}")
+ if(UNICODE)
+ set(LIBDIR "${LIBDIR}/unicode")
+@@ -72,14 +72,14 @@ endif(UNICODE)
+
+ # Installation
+ install (TARGETS ILUT
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib64
++ LIBRARY DESTINATION lib64
+ RUNTIME DESTINATION bin
+ )
+ install (FILES ../include/IL/ilut.h DESTINATION include/IL)
+
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/ILUT.pc
+- DESTINATION lib/pkgconfig
++ DESTINATION lib64/pkgconfig
+ )
+
diff --git a/libraries/DevIL/patch-include_IL_il.h b/libraries/DevIL/patch-include_IL_il.h
deleted file mode 100644
index e265db2fe4..0000000000
--- a/libraries/DevIL/patch-include_IL_il.h
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-include_IL_il.h,v 1.1 2012/07/09 19:16:33 joerg Exp $
-
---- include/IL/il.h.orig 2012-07-06 12:31:13.000000000 +0000
-+++ include/IL/il.h
-@@ -63,7 +63,7 @@ extern "C" {
- #endif
- #endif
-
--#ifdef RESTRICT_KEYWORD
-+#if defined(RESTRICT_KEYWORD) && !defined(__cplusplus)
- #define RESTRICT restrict
- #define CONST_RESTRICT const restrict
- #else