summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-27 10:50:12 +0100
committer Robby Workman <rworkman@slackbuilds.org>2022-02-27 22:29:03 -0600
commit250624dadd294669bf4d184be1294ed1dce2964f (patch)
treefe5881e9fac0454df70907b7cfbde91ad06de892
parenta5e3e6b08e780afedfc64097de00eff635588074 (diff)
downloadslackbuilds-250624dadd294669bf4d184be1294ed1dce2964f.tar.gz
slackbuilds-250624dadd294669bf4d184be1294ed1dce2964f.tar.xz
academic/Kst: Updated for version 20220116_2b8e03e.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--academic/Kst/Kst.SlackBuild20
-rw-r--r--academic/Kst/Kst.info6
-rw-r--r--academic/Kst/Kst_gsl2.patch53
3 files changed, 14 insertions, 65 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
index ebb7cca8f8..0ae8d4632f 100644
--- a/academic/Kst/Kst.SlackBuild
+++ b/academic/Kst/Kst.SlackBuild
@@ -7,7 +7,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Kst
-VERSION=${VERSION:-2.0.8}
+VERSION=${VERSION:-20220116_2b8e03e}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,7 +46,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -zxvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -55,19 +55,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix build failure with gsl-2.1 (gsl API change)
-patch -p1 < $CWD/Kst_gsl2.patch
+# Fix an issue with the newer cmake
+sed -i "s|else(GCC|elseif(GCC|" CMakeLists.txt || exit 1
sed -i "s/find_package\(PythonLibs REQUIRED\)/SET \(PythonLibs \"\/usr\/lib${LIBDIRSUFFIX}\/libpython2.7.so\"\)/" \
-./cmake/pyKst/CMakeLists.txt
-sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake
+./cmake/pyKst/CMakeLists.txt || exit 1
+sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake || exit 1
cp -r ./cmake/pyKst/* ./pyKst/
cmake ./ \
--Dkst_release=1 \
--Dkst_version_string=1 \
+-Dkst_release=2 \
+-Dkst_version_string=$VERSION \
-Dkst_svnversion=0 \
-Dkst_python=1 \
--DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
+-Dkst_qt4=OFF \
+-Dkst_qt5=ON \
+-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-Dkst_python_prefix=/usr/lib$LIBDIRSUFFIX/python2.7 \
-Dkst_install_prefix=/usr/ \
-Dkst_install_libdir=/usr/lib$LIBDIRSUFFIX
diff --git a/academic/Kst/Kst.info b/academic/Kst/Kst.info
index 8912bc7380..bb94664b66 100644
--- a/academic/Kst/Kst.info
+++ b/academic/Kst/Kst.info
@@ -1,8 +1,8 @@
PRGNAM="Kst"
-VERSION="2.0.8"
+VERSION="20220116_2b8e03e"
HOMEPAGE="https://kst-plot.kde.org/"
-DOWNLOAD="http://netcologne.dl.sourceforge.net/project/kst/Kst%202.0.8/Kst-2.0.8.tar.gz"
-MD5SUM="6f52c16edb63e8980520bfdaebed3eae"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/Kst-20220116_2b8e03e.tar.xz"
+MD5SUM="1b6e1fbe3fdfc27441140fd9b761eba4"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="scipy"
diff --git a/academic/Kst/Kst_gsl2.patch b/academic/Kst/Kst_gsl2.patch
deleted file mode 100644
index 1a7db24321..0000000000
--- a/academic/Kst/Kst_gsl2.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -u -r Kst-2.0.8/src/plugins/fits/non_linear.h Kst-2.0.8-patched/src/plugins/fits/non_linear.h
---- Kst-2.0.8/src/plugins/fits/non_linear.h 2014-02-13 09:41:44.000000000 +0000
-+++ Kst-2.0.8-patched/src/plugins/fits/non_linear.h 2015-11-18 22:28:40.761417846 +0000
-@@ -18,6 +18,7 @@
- #include <gsl/gsl_blas.h>
- #include <gsl/gsl_multifit_nlin.h>
- #include <gsl/gsl_statistics.h>
-+#include <gsl/gsl_version.h>
- #include "common.h"
-
- struct data {
-@@ -177,7 +178,15 @@
- }
- iIterations++;
- } while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
-+
-+#if GSL_MAJOR_VERSION >=2
-+ gsl_matrix *J=gsl_matrix_alloc(pSolver->fdf->n, pSolver->fdf->p);
-+ gsl_multifit_fdfsolver_jac (pSolver, J);
-+ gsl_multifit_covar( J, 0.0, pMatrixCovariance );
-+ gsl_matrix_free(J);
-+#else
- gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
-+#endif
-
- //
- // determine the fitted values...
-diff -u -r Kst-2.0.8/src/plugins/fits/non_linear_weighted.h Kst-2.0.8-patched/src/plugins/fits/non_linear_weighted.h
---- Kst-2.0.8/src/plugins/fits/non_linear_weighted.h 2014-02-13 09:41:44.000000000 +0000
-+++ Kst-2.0.8-patched/src/plugins/fits/non_linear_weighted.h 2015-11-18 22:28:44.004399807 +0000
-@@ -18,6 +18,7 @@
- #include <gsl/gsl_blas.h>
- #include <gsl/gsl_multifit_nlin.h>
- #include <gsl/gsl_statistics.h>
-+#include <gsl/gsl_version.h>
- #include "common.h"
-
- struct data {
-@@ -193,7 +194,14 @@
- }
- while( iStatus == GSL_CONTINUE && iIterations < MAX_NUM_ITERATIONS );
-
-+#if GSL_MAJOR_VERSION >=2
-+ gsl_matrix *J=gsl_matrix_alloc(pSolver->fdf->n, pSolver->fdf->p);
-+ gsl_multifit_fdfsolver_jac (pSolver, J);
-+ gsl_multifit_covar( J, 0.0, pMatrixCovariance );
-+ gsl_matrix_free(J);
-+#else
- gsl_multifit_covar( pSolver->J, 0.0, pMatrixCovariance );
-+#endif
-
- //
- // determine the fitted values...