summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-10-08 01:20:02 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-10 23:34:34 +0700
commit379b8ab73cbd89af7b3856bbe0218ea15af6aa42 (patch)
tree4a4e9c1471f45d3765d2c9978ad3bf0e31cffb38
parent11d4ef66ec148ddbea80483e2aa97fe2a4c19b52 (diff)
downloadslackbuilds-379b8ab73cbd89af7b3856bbe0218ea15af6aa42.tar.gz
slackbuilds-379b8ab73cbd89af7b3856bbe0218ea15af6aa42.tar.xz
python/testpath: Change build method to python3-flit_core
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/testpath/testpath.SlackBuild16
-rw-r--r--python/testpath/testpath.info2
2 files changed, 4 insertions, 14 deletions
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
index e6dd00699a..62d35b6814 100644
--- a/python/testpath/testpath.SlackBuild
+++ b/python/testpath/testpath.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=testpath
VERSION=${VERSION:-0.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,18 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from distutils.core import setup
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=['${PRGNAM}'],
- package_data={'': ['*']})
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/testpath/testpath.info b/python/testpath/testpath.info
index 3d601727e5..7e003a9ef5 100644
--- a/python/testpath/testpath.info
+++ b/python/testpath/testpath.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/source/t/testpath/testpath-0.6
MD5SUM="9fd4339f76da12d15bc718e4aa2566e9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-flit_core"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"