summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-31 17:44:48 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-06 08:08:43 +0700
commit3966d07734159e5b346902bcc7714784e2034ecb (patch)
tree1f64e2bc681e0ef028952f64896dc080e94e930a
parent261aee740d936d5b9a08139f72ec430331c7de19 (diff)
downloadslackbuilds-3966d07734159e5b346902bcc7714784e2034ecb.tar.gz
slackbuilds-3966d07734159e5b346902bcc7714784e2034ecb.tar.xz
python/sphinxcontrib-qthelp: Updated for version 1.0.6, new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild36
-rw-r--r--python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info12
2 files changed, 18 insertions, 30 deletions
diff --git a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
index e958055f07..db0c111daf 100644
--- a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
+++ b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-qthelp
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-qthelp
-VERSION=${VERSION:-1.0.3}
+SRCNAM=sphinxcontrib_qthelp
+VERSION=${VERSION:-1.0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,36 +51,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
index a77c661219..d8ccb02f15 100644
--- a/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
+++ b/python/sphinxcontrib-qthelp/sphinxcontrib-qthelp.info
@@ -1,10 +1,10 @@
PRGNAM="sphinxcontrib-qthelp"
-VERSION="1.0.3"
+VERSION="1.0.6"
HOMEPAGE="https://github.com/sphinx-doc/sphinxcontrib-qthelp"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.tar.gz"
-MD5SUM="93216721f3e154cce12d1e9c3307b415"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-qthelp/sphinxcontrib_qthelp-1.0.6.tar.gz"
+MD5SUM="7a945ad3b0c47e9e2777a146e38e34af"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-build"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"