summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Vijay Marcel <vijaymarcel@outlook.com>2024-05-17 08:09:24 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-17 23:00:16 +0700
commit44d74dcc4db6938f9fb4672356c71b7ad60dea81 (patch)
tree61faf554ae6f28056476d4411f61799a3ca3de07
parent379c345a0cfbdeea9eaf70b271d1145741a593b6 (diff)
downloadslackbuilds-44d74dcc4.tar.gz
slackbuilds-44d74dcc4.tar.xz
python/python3-xmldiff: Updated for version 2.7.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-xmldiff/python3-xmldiff.SlackBuild28
-rw-r--r--python/python3-xmldiff/python3-xmldiff.info6
2 files changed, 25 insertions, 9 deletions
diff --git a/python/python3-xmldiff/python3-xmldiff.SlackBuild b/python/python3-xmldiff/python3-xmldiff.SlackBuild
index 2481ca8ca5..139c1d2bb5 100644
--- a/python/python3-xmldiff/python3-xmldiff.SlackBuild
+++ b/python/python3-xmldiff/python3-xmldiff.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-xmldiff
-# Copyright 2023 Vijay Marcel
+# Copyright 2023-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-xmldiff
-VERSION=${VERSION:-2.6.3}
+VERSION=${VERSION:-2.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,6 +49,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
set -e
trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
@@ -66,14 +83,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst LICENSE.txt README.rst README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
diff --git a/python/python3-xmldiff/python3-xmldiff.info b/python/python3-xmldiff/python3-xmldiff.info
index c315aafc66..f0cf8a2513 100644
--- a/python/python3-xmldiff/python3-xmldiff.info
+++ b/python/python3-xmldiff/python3-xmldiff.info
@@ -1,8 +1,8 @@
PRGNAM="python3-xmldiff"
-VERSION="2.6.3"
+VERSION="2.7.0"
HOMEPAGE="https://github.com/Shoobx/xmldiff"
-DOWNLOAD="https://pypi.io/packages/source/x/xmldiff/xmldiff-2.6.3.tar.gz"
-MD5SUM="139f973cd3b66a642c1dd1737bce40dd"
+DOWNLOAD="https://pypi.io/packages/source/x/xmldiff/xmldiff-2.7.0.tar.gz"
+MD5SUM="3f548773840e42655c6083940e056207"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-lxml"