summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-03 19:04:59 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-04 17:53:39 +0700
commit52bb699b3e295dc94382797f502aeac0e0ed1faf (patch)
treef3f26de6eac423c6e0e535ae89c84c0eadacb350
parent6b96833c98ccabe3baa9d3024e3fe59816ba09a2 (diff)
downloadslackbuilds-52bb699b3e295dc94382797f502aeac0e0ed1faf.tar.gz
slackbuilds-52bb699b3e295dc94382797f502aeac0e0ed1faf.tar.xz
misc/fribid: Removed (not compatible with openssl-1.1.x).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--misc/fribid/README20
-rw-r--r--misc/fribid/fribid.SlackBuild132
-rw-r--r--misc/fribid/fribid.info10
-rw-r--r--misc/fribid/slack-desc19
4 files changed, 0 insertions, 181 deletions
diff --git a/misc/fribid/README b/misc/fribid/README
deleted file mode 100644
index 043df62c41..0000000000
--- a/misc/fribid/README
+++ /dev/null
@@ -1,20 +0,0 @@
-FriBID is a free program for handleing e-legitimation (electronic
-identification) with BankID. With free means that the source code is
-availible for everyone to study, copy and/or improve. FriBID is cross
-plattform and works on plattforms thats not supported by the official
-client.
-
-If you need PKCS#11 smartcard support then you need to use the PKCS11
-variable.
-
-The options are:
-PKCS11=yes
-PKCS11=runtime
-yes needs opensc installed.
-runtime adds runtime support and doesn't need opensc installed it
-can be installed later and fribid checks for opensc when started.
-Or leave it alone for disabled.
-
-Optional dependencies:
-opensc Adds PKCS#11 smartcard support if your reader is supported
-by opensc.
diff --git a/misc/fribid/fribid.SlackBuild b/misc/fribid/fribid.SlackBuild
deleted file mode 100644
index 2cf53427c7..0000000000
--- a/misc/fribid/fribid.SlackBuild
+++ /dev/null
@@ -1,132 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for fribid
-
-# Copyright 2010 Niklas "Nille" Åkerström
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=fribid
-VERSION=${VERSION:-1.0.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-# Should we build PKCS#11 smartcard support YES RUNTIME or nothing.
-PKCS11=$(echo $PKCS11 | tr 'a-z' 'A-Z')
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$PKCS11" = "YES" ]; then
- PKCS="--enable-pkcs11"
-elif [ "$PKCS11" = "RUNTIME" ]; then
- PKCS="--optional-pkcs11"
-else
- PKCS="--disable-pkcs11"
-fi
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Deborkage thanks to Arch Linux
-sed -i \
- -e 's/-DGTK_DISABLE_DEPRECATED=1//g' \
- -e 's/-DGDK_DISABLE_DEPRECATED=1//g' \
- -e 's/-DG_DISABLE_DEPRECATED=1//g' \
- client/Makefile
-sed -i \
- -e 's/strndup/strndup_/' \
- plugin/pluginutil.c
-sed -i \
- 's/_BSD_SOURCE/_DEFAULT_SOURCE/g' \
- common/*.c plugin/*.c client/*.c
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --plugin-path=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- $PKCS
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/man
-mv $PKG/usr/share/man $PKG/usr
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGELOG INSTALL LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/misc/fribid/fribid.info b/misc/fribid/fribid.info
deleted file mode 100644
index 7d9f7992fc..0000000000
--- a/misc/fribid/fribid.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="fribid"
-VERSION="1.0.4"
-HOMEPAGE="http://www.fribid.se"
-DOWNLOAD="http://www.fribid.se/releases/source/fribid-1.0.4.tar.bz2"
-MD5SUM="253e1eee92bebd5b37e0a508bda770cb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Niklas 'Nille' Åkerström"
-EMAIL="nille.kungen[AT]gmail.com"
diff --git a/misc/fribid/slack-desc b/misc/fribid/slack-desc
deleted file mode 100644
index 16067a8a47..0000000000
--- a/misc/fribid/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-fribid: fribid (program for handling e-legitimation with BankID)
-fribid:
-fribid: FriBID is a free program for handling e-legitimation with BankID.
-fribid: With free means that the source code is available for everyone to
-fribid: study, copy and/or improve.
-fribid: FriBID is cross platform and works on platforms not supported
-fribid: by the official client.
-fribid:
-fribid:
-fribid:
-fribid: