summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-05-19 22:26:35 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 15:50:05 +0700
commit64301d0afd9a6ea4faa4b505342c87b510c44a76 (patch)
treec82fb84d301768bddc7a2169cd710915b0e0f713
parent34aab4c4f66dcf22ce05bf2291e71490f18ddc63 (diff)
downloadslackbuilds-64301d0afd9a6ea4faa4b505342c87b510c44a76.tar.gz
slackbuilds-64301d0afd9a6ea4faa4b505342c87b510c44a76.tar.xz
python/async-timeout: Remove async-timeout
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/async-timeout/README1
-rw-r--r--python/async-timeout/async-timeout.SlackBuild94
-rw-r--r--python/async-timeout/async-timeout.info10
-rw-r--r--python/async-timeout/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/python/async-timeout/README b/python/async-timeout/README
deleted file mode 100644
index 8d91b81b5c..0000000000
--- a/python/async-timeout/README
+++ /dev/null
@@ -1 +0,0 @@
-async-timeout is an asyncio-compatible timeout context manager.
diff --git a/python/async-timeout/async-timeout.SlackBuild b/python/async-timeout/async-timeout.SlackBuild
deleted file mode 100644
index c0a8df300f..0000000000
--- a/python/async-timeout/async-timeout.SlackBuild
+++ /dev/null
@@ -1,94 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for async-timeout
-# Copyright 2019-2022 Isaac Yu <isaacyu1@isaacyu1.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=async-timeout
-VERSION=${VERSION:-4.0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.rst README.rst PKG-INFO LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/async-timeout/async-timeout.info b/python/async-timeout/async-timeout.info
deleted file mode 100644
index fe7396b229..0000000000
--- a/python/async-timeout/async-timeout.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="async-timeout"
-VERSION="4.0.2"
-HOMEPAGE="https://github.com/aio-libs/async-timeout"
-DOWNLOAD="https://github.com/aio-libs/async-timeout/releases/download/v4.0.2/async-timeout-4.0.2.tar.gz"
-MD5SUM="10571272b2e0fab839ec23f8293bf482"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="typing-extensions"
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
diff --git a/python/async-timeout/slack-desc b/python/async-timeout/slack-desc
deleted file mode 100644
index 262c8891e9..0000000000
--- a/python/async-timeout/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-async-timeout: async-timeout (asyncio-compatible timeout class)
-async-timeout:
-async-timeout: async-timeout is an asyncio-compatible timeout context manager.
-async-timeout:
-async-timeout: https://github.com/aio-libs/async-timeout/
-async-timeout:
-async-timeout:
-async-timeout:
-async-timeout:
-async-timeout:
-async-timeout: