summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-05-13 00:59:54 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 00:59:54 +0200
commit660abc24c65d4e556e3cb628ab9172f1ef4e4db5 (patch)
tree4ee37b6e3c439965d3d83103d8ff129c762b9855
parent4e81248ebb6fda6ca3aa4534bcc93f991f471a58 (diff)
downloadslackbuilds-660abc24c65d4e556e3cb628ab9172f1ef4e4db5.tar.gz
slackbuilds-660abc24c65d4e556e3cb628ab9172f1ef4e4db5.tar.xz
network/airpwn: Added to 13.0 repository
-rw-r--r--network/airpwn/README9
-rw-r--r--network/airpwn/airpwn.SlackBuild118
-rw-r--r--network/airpwn/airpwn.info10
-rw-r--r--network/airpwn/slack-desc19
4 files changed, 156 insertions, 0 deletions
diff --git a/network/airpwn/README b/network/airpwn/README
new file mode 100644
index 0000000000..dcae98d731
--- /dev/null
+++ b/network/airpwn/README
@@ -0,0 +1,9 @@
+Airpwn is a framework for 802.11 (wireless) packet injection.
+Airpwn listens to incoming wireless packets, and if the data
+matches a pattern specified in the config files, custom content
+is injected "spoofed" from the wireless access point. From the
+perspective of the wireless client, airpwn becomes the server.
+
+This package also installs lorcon (Loss Of Radio CONnectivity).
+
+This requires libnet.
diff --git a/network/airpwn/airpwn.SlackBuild b/network/airpwn/airpwn.SlackBuild
new file mode 100644
index 0000000000..d4c67fde3c
--- /dev/null
+++ b/network/airpwn/airpwn.SlackBuild
@@ -0,0 +1,118 @@
+#!/bin/sh
+
+# Slackware build script for airpwn
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=airpwn
+VERSION=${VERSION:-1.4}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+cd $PRGNAM-$VERSION
+tar xvf lorcon-current.tgz
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Remove some unneeded directories and change a file to Unix.
+find . -type d -name "CVS" | xargs rm -rf {} \;
+find . -type d -name ".cvs" | xargs rm -rf {} \;
+sed -i 's/\r//g' content/ftp_resp
+
+# First we need to install lorcon
+cd lorcon
+ CFLAGS="$SLKCFLAGS" \
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --datadir=/usr/share/$PRGNAM \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+# Fix airpwn files so we can use it with a Python version other than 2.4.
+PYTHON_VERSION1=$(python -c 'import sys; print sys.version[:3]')
+PYTHON_VERSION2=$(echo $PYTHON_VERSION1 | tr . _)
+
+for FILE in configure.ac conf.h config.h.in; do
+ sed -i "s|python2.4|python${PYTHON_VERSION1}|g" $FILE
+done
+sed -i "s|Python2.4|Python${PYTHON_VERSION1}|g" configure.ac
+sed -i "s|PYTHON2_4|PYTHON${PYTHON_VERSION2}|g" config.h.in
+
+autoreconf
+
+CFLAGS="$SLKCFLAGS" \
+LDFLAGS="-L${PKG}/usr/lib${LIBDIRSUFFIX}" \
+CPPFLAGS="-I${PKG}/usr/include" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Install some scripts to help get wireless devices into monitor mode.
+install -m 0755 mac80211_prep.sh $PKG/usr/sbin
+install -m 0755 madwifing_prep.sh $PKG/usr/sbin
+install -m 0755 madwifiold_prep.sh $PKG/usr/sbin
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING LICENSE lorcon/{BUGS,README,THANKS,TODO} content conf pyscripts \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+chmod 0755 $PKG/usr/doc/$PRGNAM-$VERSION/{content,conf,pyscripts}
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/airpwn/airpwn.info b/network/airpwn/airpwn.info
new file mode 100644
index 0000000000..5254e3b7fa
--- /dev/null
+++ b/network/airpwn/airpwn.info
@@ -0,0 +1,10 @@
+PRGNAM="airpwn"
+VERSION="1.4"
+HOMEPAGE="http://airpwn.sourceforge.net/Airpwn.html"
+DOWNLOAD="http://downloads.sourceforge.net/sourceforge/airpwn/airpwn-1.4.tgz"
+MD5SUM="c5538f5eadc2afa0bf3e873c4bfa2513"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="rworkman"
diff --git a/network/airpwn/slack-desc b/network/airpwn/slack-desc
new file mode 100644
index 0000000000..7a0bbf098e
--- /dev/null
+++ b/network/airpwn/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+airpwn: airpwn (framework for 802.11 packet injection)
+airpwn:
+airpwn: Airpwn is a framework for 802.11 (wireless) packet injection. Airpwn
+airpwn: listens to incoming wireless packets, and if the data matches a
+airpwn: pattern specified in the config files, custom content is injected
+airpwn: "spoofed" from the wireless access point. From the perspective of the
+airpwn: wireless client, airpwn becomes the server.
+airpwn:
+airpwn: Homepage: http://airpwn.sourceforge.net/Airpwn.html
+airpwn:
+airpwn: