summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-03-22 19:03:34 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-23 20:18:16 +0700
commita5363c93b17868fa5a093058fd50912d6d418a0f (patch)
treecec23371e5496c41a663f4d5eed9aa1064463fbf
parentecfbf772e938e6dfdc25bbce4ec902ad04952af9 (diff)
downloadslackbuilds-a5363c93b.tar.gz
slackbuilds-a5363c93b.tar.xz
python/pyinotify: Removed (renamed to python3-pyinotify)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pyinotify/README4
-rw-r--r--python/pyinotify/pyinotify.SlackBuild82
-rw-r--r--python/pyinotify/pyinotify.info10
-rw-r--r--python/pyinotify/slack-desc19
4 files changed, 0 insertions, 115 deletions
diff --git a/python/pyinotify/README b/python/pyinotify/README
deleted file mode 100644
index 40c4baeba2..0000000000
--- a/python/pyinotify/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Pyinotify is a Python module for monitoring filesystems changes.
-Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
-called inotify. inotify is an event-driven notifier, its notifications
-are exported from kernel space to user space through three system calls.
diff --git a/python/pyinotify/pyinotify.SlackBuild b/python/pyinotify/pyinotify.SlackBuild
deleted file mode 100644
index aa21d7ac1a..0000000000
--- a/python/pyinotify/pyinotify.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for pyinotify
-
-# Copyright 2012-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
-# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyinotify
-VERSION=${VERSION:-0.9.6}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Compile the C extension.
-sed -i '/^compile_ext_mod/s|=.*|= True|' setup.py
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/pyinotify/pyinotify.info b/python/pyinotify/pyinotify.info
deleted file mode 100644
index 44f6e248c5..0000000000
--- a/python/pyinotify/pyinotify.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyinotify"
-VERSION="0.9.6"
-HOMEPAGE="https://github.com/seb-m/pyinotify"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyinotify/pyinotify-0.9.6.tar.gz"
-MD5SUM="8e580fa1ff3971f94a6f81672b76c406"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu@protonmail.com"
diff --git a/python/pyinotify/slack-desc b/python/pyinotify/slack-desc
deleted file mode 100644
index c2efb9d751..0000000000
--- a/python/pyinotify/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyinotify: pyinotify (python inotify module)
-pyinotify:
-pyinotify: Pyinotify is a Python module for monitoring filesystems changes.
-pyinotify: Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
-pyinotify: called inotify. inotify is an event-driven notifier; its
-pyinotify: notifications are exported from kernel space to user space through
-pyinotify: three system calls.
-pyinotify:
-pyinotify: Homepage: https://github.com/seb-m/pyinotify
-pyinotify:
-pyinotify: