summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Jick Nan <jick.nan@gmail.com>2010-05-11 20:00:20 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:20 +0200
commitc687bc507902889eb2745a068296d9c926aec4b7 (patch)
treedc1ca004e21ed905dfe574a512418fbb354f755f
parent683e2f47cc23503e04eae443f044272f78f333d3 (diff)
downloadslackbuilds-c687bc507902889eb2745a068296d9c926aec4b7.tar.gz
slackbuilds-c687bc507902889eb2745a068296d9c926aec4b7.tar.xz
development/MySQL-python: Added to 12.0 repository
-rw-r--r--development/MySQL-python/MySQL-python.SlackBuild43
-rw-r--r--development/MySQL-python/MySQL-python.info8
-rw-r--r--development/MySQL-python/README12
-rw-r--r--development/MySQL-python/slack-desc19
4 files changed, 82 insertions, 0 deletions
diff --git a/development/MySQL-python/MySQL-python.SlackBuild b/development/MySQL-python/MySQL-python.SlackBuild
new file mode 100644
index 0000000000..7ea90707ad
--- /dev/null
+++ b/development/MySQL-python/MySQL-python.SlackBuild
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# Slackware build script for MySQL-python.
+
+# Written by Jick Nan (jick.nan@gmail.com)
+
+PRGNAM=MySQL-python
+VERSION=1.2.2
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+cd $PRGNAM-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py bdist || exit 1
+tar zxvf dist/$PRGNAM-$VERSION.linux-i686.tar.gz -C $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog GPL HISTORY PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 0644 *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/MySQL-python/MySQL-python.info b/development/MySQL-python/MySQL-python.info
new file mode 100644
index 0000000000..f53ce742b6
--- /dev/null
+++ b/development/MySQL-python/MySQL-python.info
@@ -0,0 +1,8 @@
+PRGNAM="MySQL-python"
+VERSION="1.2.2"
+HOMEPAGE="http://cheeseshop.python.org/pypi/MySQL-python/"
+DOWNLOAD="http://downloads.sourceforge.net/mysql-python/MySQL-python-1.2.2.tar.gz"
+MD5SUM="532268f02870bea18c1d465e88afff30"
+MAINTAINER="Jick Nan"
+EMAIL="jick.nan@gmail.com"
+APPROVED="rworkman"
diff --git a/development/MySQL-python/README b/development/MySQL-python/README
new file mode 100644
index 0000000000..7b08482c7e
--- /dev/null
+++ b/development/MySQL-python/README
@@ -0,0 +1,12 @@
+MySQL-python (Python interface to MySQL)
+
+MySQLdb is an interface to the popular MySQL database server for Python.
+The design goals are:
+
+ * Compliance with Python database API version 2.0 [PEP-0249]
+ * Thread-safety
+ * Thread-friendliness (threads will not block each other)
+
+MySQL-3.23 through 5.0 and Python-2.3 through 2.5 are currently supported.
+
+This requires the Python setuptools (pysetuptools on SlackBuilds.org).
diff --git a/development/MySQL-python/slack-desc b/development/MySQL-python/slack-desc
new file mode 100644
index 0000000000..3bdaf5389e
--- /dev/null
+++ b/development/MySQL-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+MySQL-python: MySQL-python (Python interface to MySQL)
+MySQL-python:
+MySQL-python: MySQLdb is an interface to the popular MySQL database server
+MySQL-python: for Python. The design goals are:
+MySQL-python: * Compliance with Python database API version 2.0 [PEP-0249]
+MySQL-python: * Thread-safety
+MySQL-python: * Thread-friendliness (threads will not block each other)
+MySQL-python:
+MySQL-python: MySQL-3.23 through 5.0 and Python-2.3 through 2.5 are currently
+MySQL-python: supported.
+MySQL-python: