summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2018-03-14 23:05:08 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-03-17 08:51:43 +0700
commitd8fb6076da00cd74ee6da5373d543f0979e8edf9 (patch)
tree0adc2dc060f2ae9a201e912a0eb388ff9745b51e
parentf8afedac7ee1e819bca29d772e19c14fe66100a1 (diff)
downloadslackbuilds-d8fb6076da00cd74ee6da5373d543f0979e8edf9.tar.gz
slackbuilds-d8fb6076da00cd74ee6da5373d543f0979e8edf9.tar.xz
gis/geographiclib-python: Add Python 3 support.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--gis/geographiclib-python/geographiclib-python.SlackBuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/gis/geographiclib-python/geographiclib-python.SlackBuild b/gis/geographiclib-python/geographiclib-python.SlackBuild
index c9c9e83751..09a90d09fe 100644
--- a/gis/geographiclib-python/geographiclib-python.SlackBuild
+++ b/gis/geographiclib-python/geographiclib-python.SlackBuild
@@ -66,12 +66,15 @@ tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \