summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2021-11-06 12:44:21 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-11-12 00:39:43 +0700
commitecbcdaef3defdff133fd66e5b42638e96a166e7b (patch)
treeef3e0c8e70eafc10032edada5a837d25657dde03
parentcfb7a853d526140ddca3829713ad8f879745c84d (diff)
downloadslackbuilds-ecbcdaef3defdff133fd66e5b42638e96a166e7b.tar.gz
slackbuilds-ecbcdaef3defdff133fd66e5b42638e96a166e7b.tar.xz
development/device-tree-compiler: Respect DESTDIR in python install
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/device-tree-compiler/device-tree-compiler.SlackBuild4
-rw-r--r--development/device-tree-compiler/fix-python-destdir-usage.diff12
2 files changed, 15 insertions, 1 deletions
diff --git a/development/device-tree-compiler/device-tree-compiler.SlackBuild b/development/device-tree-compiler/device-tree-compiler.SlackBuild
index ee915a2086..99e85fda84 100644
--- a/development/device-tree-compiler/device-tree-compiler.SlackBuild
+++ b/development/device-tree-compiler/device-tree-compiler.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=device-tree-compiler
VERSION=${VERSION:-1.6.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,6 +81,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/fix-python-destdir-usage.diff
+
make clean
make CFLAGS="$SLKCFLAGS -w -Wl,--allow-multiple-definition" PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX}
make install PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG
diff --git a/development/device-tree-compiler/fix-python-destdir-usage.diff b/development/device-tree-compiler/fix-python-destdir-usage.diff
new file mode 100644
index 0000000000..49b3c14d5b
--- /dev/null
+++ b/development/device-tree-compiler/fix-python-destdir-usage.diff
@@ -0,0 +1,12 @@
+diff -Nur device-tree-compiler-1.6.0.orig/pylibfdt/Makefile.pylibfdt device-tree-compiler-1.6.0/pylibfdt/Makefile.pylibfdt
+--- device-tree-compiler-1.6.0.orig/pylibfdt/Makefile.pylibfdt 2020-03-04 00:14:58.000000000 -0600
++++ device-tree-compiler-1.6.0/pylibfdt/Makefile.pylibfdt 2021-11-06 12:38:30.133022247 -0500
+@@ -22,7 +22,7 @@
+
+ install_pylibfdt: $(PYMODULE)
+ @$(VECHO) INSTALL-PYLIB
+- $(PYTHON) $(SETUP) $(SETUPFLAGS) install --prefix=$(PREFIX)
++ $(PYTHON) $(SETUP) $(SETUPFLAGS) install --prefix=$(PREFIX) --root=$(DESTDIR)
+
+ pylibfdt_clean:
+ @$(VECHO) CLEAN "(pylibfdt)"