summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Vijay Marcel <vijaymarcel@outlook.com>2024-05-17 08:09:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-17 23:03:37 +0700
commitee6fbd0bb49454b667be55e5fed5eb3bfbd8994d (patch)
tree2e1d2c9224bce12ecca818082a58882d3ede8a55
parent44d74dcc4db6938f9fb4672356c71b7ad60dea81 (diff)
downloadslackbuilds-ee6fbd0bb.tar.gz
slackbuilds-ee6fbd0bb.tar.xz
python/python3-marisa-trie: Updated for version 1.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-marisa-trie/python3-marisa-trie.SlackBuild16
-rw-r--r--python/python3-marisa-trie/python3-marisa-trie.info6
2 files changed, 11 insertions, 11 deletions
diff --git a/python/python3-marisa-trie/python3-marisa-trie.SlackBuild b/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
index 15417683bd..97e1fa963e 100644
--- a/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
+++ b/python/python3-marisa-trie/python3-marisa-trie.SlackBuild
@@ -25,11 +25,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-marisa-trie
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=${SRCNAM:-marisa-trie}
+SRCNAM=${SRCNAM:-marisa_trie}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -49,13 +49,13 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i586 -mtune=i686 -pipe -O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2"
LIBDIRSUFFIX="64"
elif [ "$ARCH" = "aarch64" ]; then
SLKCFLAGS="-O2 -fPIC"
@@ -82,12 +82,12 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -pv $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS.rst CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
diff --git a/python/python3-marisa-trie/python3-marisa-trie.info b/python/python3-marisa-trie/python3-marisa-trie.info
index 342c5131ef..94fbf34864 100644
--- a/python/python3-marisa-trie/python3-marisa-trie.info
+++ b/python/python3-marisa-trie/python3-marisa-trie.info
@@ -1,8 +1,8 @@
PRGNAM="python3-marisa-trie"
-VERSION="1.1.0"
+VERSION="1.1.1"
HOMEPAGE="https://github.com/pytries/marisa-trie"
-DOWNLOAD="https://pypi.io/packages/source/m/marisa-trie/marisa-trie-1.1.0.tar.gz"
-MD5SUM="a98fd6023f47957a8039786fc39b5ae1"
+DOWNLOAD="https://pypi.io/packages/source/m/marisa-trie/marisa_trie-1.1.1.tar.gz"
+MD5SUM="f9ba2f0a2e8a9d108d00bd3221e0548d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""