summaryrefslogtreecommitdiffstats
path: root/academic/Kst/Kst.SlackBuild
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-02-27 10:50:12 +0100
committer Robby Workman <rworkman@slackbuilds.org>2022-02-27 22:29:03 -0600
commit250624dadd294669bf4d184be1294ed1dce2964f (patch)
treefe5881e9fac0454df70907b7cfbde91ad06de892 /academic/Kst/Kst.SlackBuild
parenta5e3e6b08e780afedfc64097de00eff635588074 (diff)
downloadslackbuilds-250624dadd294669bf4d184be1294ed1dce2964f.tar.gz
slackbuilds-250624dadd294669bf4d184be1294ed1dce2964f.tar.xz
academic/Kst: Updated for version 20220116_2b8e03e.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'academic/Kst/Kst.SlackBuild')
-rw-r--r--academic/Kst/Kst.SlackBuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
index ebb7cca8f8..0ae8d4632f 100644
--- a/academic/Kst/Kst.SlackBuild
+++ b/academic/Kst/Kst.SlackBuild
@@ -7,7 +7,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Kst
-VERSION=${VERSION:-2.0.8}
+VERSION=${VERSION:-20220116_2b8e03e}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,7 +46,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -zxvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -55,19 +55,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix build failure with gsl-2.1 (gsl API change)
-patch -p1 < $CWD/Kst_gsl2.patch
+# Fix an issue with the newer cmake
+sed -i "s|else(GCC|elseif(GCC|" CMakeLists.txt || exit 1
sed -i "s/find_package\(PythonLibs REQUIRED\)/SET \(PythonLibs \"\/usr\/lib${LIBDIRSUFFIX}\/libpython2.7.so\"\)/" \
-./cmake/pyKst/CMakeLists.txt
-sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake
+./cmake/pyKst/CMakeLists.txt || exit 1
+sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake || exit 1
cp -r ./cmake/pyKst/* ./pyKst/
cmake ./ \
--Dkst_release=1 \
--Dkst_version_string=1 \
+-Dkst_release=2 \
+-Dkst_version_string=$VERSION \
-Dkst_svnversion=0 \
-Dkst_python=1 \
--DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
+-Dkst_qt4=OFF \
+-Dkst_qt5=ON \
+-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-Dkst_python_prefix=/usr/lib$LIBDIRSUFFIX/python2.7 \
-Dkst_install_prefix=/usr/ \
-Dkst_install_libdir=/usr/lib$LIBDIRSUFFIX