summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/pngnq-s9/pngnq-s9.SlackBuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/pngnq-s9/pngnq-s9.SlackBuild b/multimedia/pngnq-s9/pngnq-s9.SlackBuild
index 7f3b0446c8..2e4de17ffc 100644
--- a/multimedia/pngnq-s9/pngnq-s9.SlackBuild
+++ b/multimedia/pngnq-s9/pngnq-s9.SlackBuild
@@ -21,7 +21,7 @@
PRGNAM=pngnq-s9
VERSION=${VERSION:-2.0.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,9 +64,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix build on newer toolchain, thanks to adrien
+sed -i 's/AM_INIT_AUTOMAKE\[-Wall -Werror\]/AM_INIT_AUTOMAKE/' configure.ac
+autoreconf -vif
-autoreconf -vi
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \