summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/ming/README9
-rw-r--r--development/ming/doinst.sh15
-rw-r--r--development/ming/ming.SlackBuild134
-rw-r--r--development/ming/ming.info10
-rw-r--r--development/ming/ming.ini2
-rw-r--r--development/ming/slack-desc19
6 files changed, 0 insertions, 189 deletions
diff --git a/development/ming/README b/development/ming/README
deleted file mode 100644
index 02b3eb5f17..0000000000
--- a/development/ming/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Ming is a Flash (SWF) output library. It can be used from PHP,
-Perl, Ruby, Python, C, C++, Java, and probably more on the way.
-It comprises a lot of Flash functionality, including features
-of Flash 6. Specifically, it lets you create: shapes (including
-morphs), text, sprites (aka movie clips), buttons, and actions
-in flash movies, plus more. The goal for Ming is to abstract
-away all of the mundane specifics of the SWF file format.
-
-This builds the c++, perl, python and tcl-plugin.
diff --git a/development/ming/doinst.sh b/development/ming/doinst.sh
deleted file mode 100644
index 79b0704b6c..0000000000
--- a/development/ming/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD|md5sum)" = "$(cat $NEW|md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-#config etc/php.d/ming.ini.new
-
diff --git a/development/ming/ming.SlackBuild b/development/ming/ming.SlackBuild
deleted file mode 100644
index 9486503c6a..0000000000
--- a/development/ming/ming.SlackBuild
+++ /dev/null
@@ -1,134 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for ming
-
-# Copyright 2008-2017 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=ming
-SRCNAM=libming-ming
-VERSION=${VERSION:-0.4.8}
-TARVERSION=$(echo $VERSION | tr . _)
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$TARVERSION
-tar xvf $CWD/$SRCNAM-$TARVERSION.tar.gz
-cd $SRCNAM-$TARVERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-autoreconf -vif
-
-# static library is activated because the perl extension needs it
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-static \
- --enable-tcl \
- --build=$ARCH-slackware-linux
-
-make -j1
-make install DESTDIR=$PKG
-
-# Building the php extension against a zts enabled php fails currently.
-# Feel free to uncomment this in case you have a normal php. -HW
-
-#cd php_ext
-# make install DESTDIR=$PKG
-#cd -
-
-# Install config file for PHP.
-#install -D -m 644 $CWD/ming.ini $PKG/etc/php.d/ming.ini.new
-
-cd py_ext
- python setup.py install --root=$PKG
-cd -
-
-cd perl_ext
- perl Makefile.PL INSTALLDIRS=vendor
- make
- make install DESTDIR=$PKG
-cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-mkdir -p $PKG/usr/man/man3
-mv $PKG/usr/share/man/man3/* $PKG/usr/man/man3/
-rm -rf $PKG/usr/share
-
-find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
-find $PKG -depth -type d -empty -delete || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS HISTORY INSTALL LICENSE* NEWS README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/ming/ming.info b/development/ming/ming.info
deleted file mode 100644
index 84fc164c45..0000000000
--- a/development/ming/ming.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ming"
-VERSION="0.4.8"
-HOMEPAGE="http://www.libming.org"
-DOWNLOAD="https://github.com/libming/libming/archive/ming-0_4_8/libming-ming-0_4_8.tar.gz"
-MD5SUM="70c28c1e41d5888aa158e6e15644b742"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
diff --git a/development/ming/ming.ini b/development/ming/ming.ini
deleted file mode 100644
index d73fcb9595..0000000000
--- a/development/ming/ming.ini
+++ /dev/null
@@ -1,2 +0,0 @@
-; Enable ming extension module
-; extension=ming.so
diff --git a/development/ming/slack-desc b/development/ming/slack-desc
deleted file mode 100644
index d61b1a0c14..0000000000
--- a/development/ming/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ming: ming (swf output library)
-ming:
-ming: Ming is a Flash (SWF) output library. It can be used from PHP,
-ming: Perl, Ruby, Python, C, C++, Java, and probably more on the way.
-ming: It comprises a lot of Flash functionality, including features
-ming: of Flash 6. Specifically, it lets you create: shapes (including
-ming: morphs), text, sprites (aka movie clips), buttons, and actions
-ming: in flash movies, plus more. The goal for Ming is to abstract
-ming: away all of the mundane specifics of the SWF file format.
-ming:
-ming: Homepage: http://www.libming.org