summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-Flask-RESTful/python3-Flask-RESTful.SlackBuild14
-rw-r--r--python/python3-Flask-RESTful/python3-Flask-RESTful.info6
2 files changed, 10 insertions, 10 deletions
diff --git a/python/python3-Flask-RESTful/python3-Flask-RESTful.SlackBuild b/python/python3-Flask-RESTful/python3-Flask-RESTful.SlackBuild
index 119ab1a4a4..c8928a8fd9 100644
--- a/python/python3-Flask-RESTful/python3-Flask-RESTful.SlackBuild
+++ b/python/python3-Flask-RESTful/python3-Flask-RESTful.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-RESTful
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -30,7 +30,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-RESTful
SRCNAM=Flask-RESTful
-VERSION=${VERSION:-0.3.9}
+VERSION=${VERSION:-0.3.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -43,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -64,6 +61,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -80,9 +80,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-Flask-RESTful/python3-Flask-RESTful.info b/python/python3-Flask-RESTful/python3-Flask-RESTful.info
index 924032d6a8..92c3de04f8 100644
--- a/python/python3-Flask-RESTful/python3-Flask-RESTful.info
+++ b/python/python3-Flask-RESTful/python3-Flask-RESTful.info
@@ -1,8 +1,8 @@
PRGNAM="python3-Flask-RESTful"
-VERSION="0.3.9"
+VERSION="0.3.10"
HOMEPAGE="https://github.com/flask-restful/flask-restful/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-restful/Flask-RESTful-0.3.9.tar.gz"
-MD5SUM="d5c3e0b452722297a2f1446b7ee54e53"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-restful/Flask-RESTful-0.3.10.tar.gz"
+MD5SUM="2a1f17e91c526a03bf721e178d8fce94"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-aniso8601 Flask pytz"