summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/gtorrentviewer/gtorrentviewer.SlackBuild5
-rw-r--r--network/gtorrentviewer/patches/fix_linking_libm.diff12
2 files changed, 16 insertions, 1 deletions
diff --git a/network/gtorrentviewer/gtorrentviewer.SlackBuild b/network/gtorrentviewer/gtorrentviewer.SlackBuild
index 2e8842f4e5..40bdec7a42 100644
--- a/network/gtorrentviewer/gtorrentviewer.SlackBuild
+++ b/network/gtorrentviewer/gtorrentviewer.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=gtorrentviewer
VERSION=${VERSION:-0.2b}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,9 @@ find . \
# Fix building against newer cURL
sed -i 's|#include <curl/types.h>||g' src/main.c
+# Fix linking of libm
+patch -p1 < $CWD/patches/fix_linking_libm.diff
+
# The following 2 patches are from Fedora 13
# Let drag and drop work with URIs as well as files
diff --git a/network/gtorrentviewer/patches/fix_linking_libm.diff b/network/gtorrentviewer/patches/fix_linking_libm.diff
new file mode 100644
index 0000000000..4be5b63bb3
--- /dev/null
+++ b/network/gtorrentviewer/patches/fix_linking_libm.diff
@@ -0,0 +1,12 @@
+diff -Nur GTorrentViewer-0.2b.orig/src/Makefile.in GTorrentViewer-0.2b/src/Makefile.in
+--- GTorrentViewer-0.2b.orig/src/Makefile.in 2004-10-25 23:42:16.000000000 -0500
++++ GTorrentViewer-0.2b/src/Makefile.in 2012-09-09 23:31:34.092115981 -0500
+@@ -115,7 +115,7 @@
+
+ CFLAGS = @CFLAGS@ @CURL_CFLAGS@ @GTK_CFLAGS@
+
+-LDADD = @GTK_LIBS@ @CURL_LIBS@
++LDADD = @GTK_LIBS@ @CURL_LIBS@ -lm
+
+ bin_PROGRAMS = gtorrentviewer
+