summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python3-Flask-Dance/README3
-rw-r--r--python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild98
-rw-r--r--python/python3-Flask-Dance/python3-Flask-Dance.info10
-rw-r--r--python/python3-Flask-Dance/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/python3-Flask-Dance/README b/python/python3-Flask-Dance/README
new file mode 100644
index 0000000000..490042eb5f
--- /dev/null
+++ b/python/python3-Flask-Dance/README
@@ -0,0 +1,3 @@
+Doing the OAuth dance with style using Flask, requests, and
+oauthlib. Currently, only OAuth consumers are supported, but this
+project could easily support OAuth providers in the future, as well.
diff --git a/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild b/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
new file mode 100644
index 0000000000..5c3046d319
--- /dev/null
+++ b/python/python3-Flask-Dance/python3-Flask-Dance.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for python3-Flask-Dance
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# 20220512 46and2: Updated version to support newer Flask and werkzeug.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-Flask-Dance
+SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
+VERSION=${VERSION:-6.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE CHANGELOG.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-Flask-Dance/python3-Flask-Dance.info b/python/python3-Flask-Dance/python3-Flask-Dance.info
new file mode 100644
index 0000000000..b13b229919
--- /dev/null
+++ b/python/python3-Flask-Dance/python3-Flask-Dance.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-Flask-Dance"
+VERSION="6.0.0"
+HOMEPAGE="https://github.com/singingwolfboy/flask-dance"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-dance/Flask-Dance-6.0.0.tar.gz"
+MD5SUM="66167365f8308bbfaaa951d5fb645013"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="Flask requests-oauthlib python3-urlobject"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python3-Flask-Dance/slack-desc b/python/python3-Flask-Dance/slack-desc
new file mode 100644
index 0000000000..29e1637e23
--- /dev/null
+++ b/python/python3-Flask-Dance/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-Flask-Dance: python3-Flask-Dance (Doing the OAuth using Flask)
+python3-Flask-Dance:
+python3-Flask-Dance: Doing the OAuth dance with style using Flask, requests,
+python3-Flask-Dance: and oauthlib. Currently, only OAuth consumers are supported,
+python3-Flask-Dance: but this project could easily support OAuth providers
+python3-Flask-Dance: in the future, as well.
+python3-Flask-Dance:
+python3-Flask-Dance: Homepage: https://github.com/singingwolfboy/flask-dance
+python3-Flask-Dance:
+python3-Flask-Dance:
+python3-Flask-Dance: