summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--development/spyder/README2
-rw-r--r--development/spyder/spyder.SlackBuild35
-rw-r--r--development/spyder/spyder.info8
3 files changed, 29 insertions, 16 deletions
diff --git a/development/spyder/README b/development/spyder/README
index a477bdefd3..7875cd2e34 100644
--- a/development/spyder/README
+++ b/development/spyder/README
@@ -3,4 +3,4 @@ environment for the Python language with advanced editing, interactive testing,
debugging and introspection features.
Optional dependencies for spyder are ipython, rope, matplotlib, numpy,
-pyflakes, pep8, pylint, and scipy.
+pyflakes, pep8, pylint, Sphinx and scipy.
diff --git a/development/spyder/spyder.SlackBuild b/development/spyder/spyder.SlackBuild
index dd0da2a043..f5b967f684 100644
--- a/development/spyder/spyder.SlackBuild
+++ b/development/spyder/spyder.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for spyder
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2010-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spyder
-VERSION=${VERSION:-2.1.11}
+VERSION=${VERSION:-2.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,29 +71,24 @@ find . \
# Sphinx craps out when files are in Windows format. We need to
# change doc/conf.py to Unix format. Simple hack! :/
-for FILE in $(find . -type f -exec grep -Pl '\r\n' {} \;); do
+for FILE in $(find . -type f \( ! -iname "*\.*o" ! -iname "*\.png" \) \
+| xargs grep -Pl '\r$');
+do
sed -i 's/\r//g' $FILE
done
-# Use the license found in the __init__.py file
-cat spyderlib/__init__.py | head -n 27 | tail -n 25 > LICENSE
-
-# Fix the .desktop item.
-sed -i 's|Science;||' scripts/$PRGNAM.desktop
-printf "\nIcon=$PRGNAM\n" >> scripts/$PRGNAM.desktop
-
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-install -D -m 0644 scripts/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
for i in 16 24 32 36 48 64 96 128; do
convert spyderlib/images/$PRGNAM.svg -resize ${i}x${i}! $PRGNAM-$i.png
install -D -m 0644 $PRGNAM-$i.png $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
done
install -D -m 0644 spyderlib/images/$PRGNAM.svg \
$PKG/usr/share/icons/hicolor/scalable/apps/$PRGNAM.svg
+rm -rf $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO README LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/development/spyder/spyder.info b/development/spyder/spyder.info
index b44b402d73..7e81d43e78 100644
--- a/development/spyder/spyder.info
+++ b/development/spyder/spyder.info
@@ -1,10 +1,10 @@
PRGNAM="spyder"
-VERSION="2.1.11"
+VERSION="2.2.5"
HOMEPAGE="http://code.google.com/p/spyderlib/"
-DOWNLOAD="http://spyderlib.googlecode.com/files/spyder-2.1.11.zip"
-MD5SUM="f095fa5694e51a229c5b938e2a627e42"
+DOWNLOAD="http://spyderlib.googlecode.com/files/spyder-2.2.5.zip"
+MD5SUM="1c9aa650dae9f883616e917803f8a3be"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="Sphinx"
+REQUIRES="%README%"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"