summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/urlgrabber/README7
-rw-r--r--network/urlgrabber/slack-desc11
-rw-r--r--network/urlgrabber/urlgrabber.SlackBuild73
-rw-r--r--network/urlgrabber/urlgrabber.info8
4 files changed, 99 insertions, 0 deletions
diff --git a/network/urlgrabber/README b/network/urlgrabber/README
new file mode 100644
index 0000000000..748e0faf99
--- /dev/null
+++ b/network/urlgrabber/README
@@ -0,0 +1,7 @@
+urlgrabber is a pure python package that drastically simplifies the fetching of
+files. It is designed to be used in programs that need common (but not
+necessarily simple) url-fetching features. It is extremely simple to drop into
+an existing program and provides a clean interface to protocol-independant
+file-access. Best of all, urlgrabber takes care of all those pesky
+file-fetching details, and lets you focus on whatever it is that your program
+is written to do!
diff --git a/network/urlgrabber/slack-desc b/network/urlgrabber/slack-desc
new file mode 100644
index 0000000000..773bf7d77a
--- /dev/null
+++ b/network/urlgrabber/slack-desc
@@ -0,0 +1,11 @@
+urlgrabber: urlgrabber (python url-fetching module)
+urlgrabber:
+urlgrabber: urlgrabber is a pure python package that drastically simplifies the
+urlgrabber: fetching of files. It is designed to be used in programs that need
+urlgrabber: common (but not necessarily simple) url-fetching features. It is
+urlgrabber: extremely simple to drop into an existing program and provides a
+urlgrabber: clean interface to protocol-independant file-access. Best of all,
+urlgrabber: urlgrabber takes care of all those pesky file-fetching details, and
+urlgrabber: lets you focus on whatever it is that your program is written to
+urlgrabber: do!
+urlgrabber:
diff --git a/network/urlgrabber/urlgrabber.SlackBuild b/network/urlgrabber/urlgrabber.SlackBuild
new file mode 100644
index 0000000000..a326d66327
--- /dev/null
+++ b/network/urlgrabber/urlgrabber.SlackBuild
@@ -0,0 +1,73 @@
+#!/bin/sh
+
+# Slackware build script for urlgrabber
+
+# Copyright (c) 2007 Daniel de Kok <moc.mikciat@leinad>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# modified by Javier Rojas to fit urlgrabber
+
+# Exit on most errors
+set -e
+
+PRGNAM=urlgrabber
+VERSION=3.1.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENSE README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# there are doc files on /usr/share (duplicated on /usr/doc)
+rm -r $PKG/usr/share/doc
+rmdir $PKG/usr/share || true # if there is anything else on /usr/share, leave it alone
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/network/urlgrabber/urlgrabber.info b/network/urlgrabber/urlgrabber.info
new file mode 100644
index 0000000000..598947ef29
--- /dev/null
+++ b/network/urlgrabber/urlgrabber.info
@@ -0,0 +1,8 @@
+PRGNAM="urlgrabber"
+VERSION="3.1.0"
+HOMEPAGE="http://linux.duke.edu/projects/urlgrabber/"
+DOWNLOAD="http://linux.duke.edu/projects/urlgrabber/download/urlgrabber-3.1.0.tar.gz"
+MD5SUM="2a92d8ce0d89c5e772a98e9b8dcd5b73"
+MAINTAINER="Javier Rojas"
+EMAIL="jerojasro@devnull.li"
+APPROVED="dsomero"