summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/audtty/README10
-rw-r--r--audio/audtty/audtty-0.1.9a-cc-and-destdir.patch30
-rw-r--r--audio/audtty/audtty.SlackBuild105
-rw-r--r--audio/audtty/audtty.info8
-rw-r--r--audio/audtty/slack-desc19
5 files changed, 172 insertions, 0 deletions
diff --git a/audio/audtty/README b/audio/audtty/README
new file mode 100644
index 0000000000..3e51d02ba7
--- /dev/null
+++ b/audio/audtty/README
@@ -0,0 +1,10 @@
+audtty is a simple application for controlling Audacious from the command line
+whether locally or remotely with a friendly ncurses interface.
+
+It is designed to make common, simple tasks fast and easy to do.
+It is operated using arrow keys and standard Audacious keys, to make it easy
+and intuitive to learn. It is a fork of xmms-curses.
+
+To run audtty over ssh or on a separete TTY locally download and run:
+http://audtty.alioth.debian.org/audtty/dbus.sh in a terminal on your desktop,
+Once run add ~/.dbus-session to your ~/.bashrc file.
diff --git a/audio/audtty/audtty-0.1.9a-cc-and-destdir.patch b/audio/audtty/audtty-0.1.9a-cc-and-destdir.patch
new file mode 100644
index 0000000000..fb78cf75f4
--- /dev/null
+++ b/audio/audtty/audtty-0.1.9a-cc-and-destdir.patch
@@ -0,0 +1,30 @@
+diff -ur audtty.orig/Makefile.in audtty/Makefile.in
+--- audtty.orig/Makefile.in 2008-05-08 09:50:26.000000000 +0300
++++ audtty/Makefile.in 2008-07-05 09:36:31.000000000 +0300
+@@ -20,18 +20,18 @@
+ all: audtty
+
+ audtty: ${BINS}
+- cc -Wall -lncurses -laudclient ${LDFLAGS} -o audtty $(BINS)
++ $(CC) -Wall ${LDFLAGS} -o audtty $(BINS) -lncurses -laudclient
+
+ .c.o:
+- cc -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
++ $(CC) -Wall ${AUDACIOUS_CFLAGS} ${CFLAGS} -o $@ -c $<
+
+ install: audtty
+- mkdir -p ${bindir}
+- install -m 0755 audtty ${bindir}/audtty
+- mkdir -p ${mandir}
+- install -m 0644 audtty.1 ${mandir}/audtty.1
+- mkdir -p ${sysconfdir}
+- install -m 0644 audtty.conf ${sysconfdir}/audtty.conf
++ mkdir -p $(DESTDIR)${bindir}
++ install -m 0755 audtty $(DESTDIR)${bindir}/audtty
++ mkdir -p $(DESTDIR)${mandir}
++ install -m 0644 audtty.1 $(DESTDIR)${mandir}/audtty.1
++ mkdir -p $(DESTDIR)${sysconfdir}
++ install -m 0644 audtty.conf $(DESTDIR)${sysconfdir}/audtty.conf
+
+ uninstall:
+ rm ${bindir}/audtty || false
diff --git a/audio/audtty/audtty.SlackBuild b/audio/audtty/audtty.SlackBuild
new file mode 100644
index 0000000000..031c96a399
--- /dev/null
+++ b/audio/audtty/audtty.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for audtty
+
+# Copyright 2009 Manuel Mantilla, Veracruz, Mexico.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=audtty
+VERSION=${VERSION:-0.1.9a}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+# Since audtty-0.1.9a.tar.gz unpacks as 'auddty' fix it by:
+mv $TMP/$PRGNAM $TMP/$PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Patch from Gentoo Linux (fixes DESTDIR)
+patch -p1 < $CWD/audtty-0.1.9a-cc-and-destdir.patch || exit 1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+# Move man pages to /usr/man manually
+mv $PKG/usr/share/man $PKG/usr/
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README ChangeLog COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/audio/audtty/audtty.info b/audio/audtty/audtty.info
new file mode 100644
index 0000000000..3c204f76f4
--- /dev/null
+++ b/audio/audtty/audtty.info
@@ -0,0 +1,8 @@
+PRGNAM="audtty"
+VERSION="0.1.9a"
+HOMEPAGE="http://audtty.alioth.debian.org"
+DOWNLOAD="http://audtty.alioth.debian.org/audtty/audtty-0.1.9a.tar.gz"
+MD5SUM="4f4de3c31ef90885eb8bea71d69ca653"
+MAINTAINER="Manuel Mantilla"
+EMAIL="mannynix@megared.net.mx"
+APPROVED="dsomero"
diff --git a/audio/audtty/slack-desc b/audio/audtty/slack-desc
new file mode 100644
index 0000000000..94f0b9cbe8
--- /dev/null
+++ b/audio/audtty/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+audtty: audtty (ncurses terminal frontend to the Audacious Media Player)
+audtty:
+audtty: audtty makes it easy to control the Audacious Media Player from the
+audtty: command line whether locally or remotely with a friendly ncurses
+audtty: interface.
+audtty:
+audtty: It is a fork of xmms-curses and is designed to be lightweight and
+audtty: intuitive to use.
+audtty:
+audtty: Homepage: http://audtty.alioth.debian.org
+audtty: