summaryrefslogtreecommitdiffstats
path: root/academic/PhyML/PhyML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/PhyML/PhyML.SlackBuild')
-rw-r--r--academic/PhyML/PhyML.SlackBuild84
1 files changed, 49 insertions, 35 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index 893454e123..351fde6f1f 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for PhyML
-# Copyright 2011-2020 Petar Petrov slackalaxy@gmail.com
+# Copyright 2011-2022 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,10 +24,13 @@
# Thanks to Niels Horn for some handy modifications and corrections.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=PhyML
-VERSION=${VERSION:-3.3.20200621}
+VERSION=${VERSION:-3.3.20220408}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
@@ -39,7 +42,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -113,45 +123,49 @@ sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
-# This is Phyrex
-./autogen.sh
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-phyrex \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Use our CFLAGS
+# This is Phyrex but it breaks at the moment
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-phyrex \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+ # Use our CFLAGS
sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
make install DESTDIR=$PKG
-# This is PhyTime
-./autogen.sh
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-phytime \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
-
-CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
-make install DESTDIR=$PKG
+# # This is PhyTime
+# ./autogen.sh
+# ./configure \
+# --prefix=/usr \
+# --libdir=/usr/lib${LIBDIRSUFFIX} \
+# --sysconfdir=/etc \
+# --localstatedir=/var \
+# --mandir=/usr/man \
+# --enable-phytime \
+# --docdir=/usr/doc/$PRGNAM-$VERSION \
+# --build=$ARCH-slackware-linux
+#
+# # Use our CFLAGS
+# sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
+#
+# CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
+# make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# fix permissions for docs
+chmod 0644 doc/*.{pdf,tex,bib}
+chmod 0644 doc/fig/*.pdf
+
# Include some examples
mkdir -p $PKG/usr/share/$PRGNAM
cp -a examples $PKG/usr/share/$PRGNAM
@@ -167,4 +181,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE