summaryrefslogtreecommitdiffstats
path: root/academic/bpp1.9-seq
diff options
context:
space:
mode:
Diffstat (limited to 'academic/bpp1.9-seq')
-rw-r--r--academic/bpp1.9-seq/bpp1.9-seq.SlackBuild14
-rw-r--r--academic/bpp1.9-seq/bpp1.9-seq.info2
2 files changed, 6 insertions, 10 deletions
diff --git a/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild b/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild
index 4d076f1a69..fcea3aef1d 100644
--- a/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild
+++ b/academic/bpp1.9-seq/bpp1.9-seq.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for bpp1.9-seq
-# Copyright 2020-2021 Petar Petrov slackalaxy@gmail.com
+# Copyright 2020-2022 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -65,7 +62,6 @@ else
LIBDIRSUFFIX=""
fi
-# This is needed for vCAPS to find its libraries at runtime. Thanks Urchlay!
LIBDIRPATH="-Wl,-rpath,/usr/lib${LIBDIRSUFFIX}/Bpp1.9"
set -e
@@ -87,6 +83,8 @@ find -L . \
export PATH="/usr/lib${LIBDIRSUFFIX}/Bpp1.9/:$PATH"
sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Seq.spec
+source /etc/profile.d/gcc5.sh
+
mkdir -p build
cd build
cmake \
@@ -101,15 +99,13 @@ cd build
make DESTDIR=$PKG install
cd ..
-# Remove static lib
-rm -f $PKG/usr/lib64/Bpp1.9/libbpp-seq.a
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 0644 AUTHORS ChangeLog COPYING
cp -a \
- AUTHORS ChangeLog COPYING INSTALL \
+ AUTHORS ChangeLog COPYING \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/academic/bpp1.9-seq/bpp1.9-seq.info b/academic/bpp1.9-seq/bpp1.9-seq.info
index 35b6d40f95..0d6d9f38df 100644
--- a/academic/bpp1.9-seq/bpp1.9-seq.info
+++ b/academic/bpp1.9-seq/bpp1.9-seq.info
@@ -1,7 +1,7 @@
PRGNAM="bpp1.9-seq"
VERSION="1.7.0"
HOMEPAGE="http://biopp.univ-montp2.fr/"
-DOWNLOAD="http://biopp.univ-montp2.fr/repos/sources/bpp-seq-1.7.0.tar.gz"
+DOWNLOAD="https://raw.githubusercontent.com/slackalaxy/sources/main/bpp-seq-1.7.0.tar.gz"
MD5SUM="4256293637ac4131c0d030f5265b8b8b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""