summaryrefslogtreecommitdiffstats
path: root/academic/sword/sword.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/sword/sword.SlackBuild')
-rw-r--r--academic/sword/sword.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/academic/sword/sword.SlackBuild b/academic/sword/sword.SlackBuild
index ac8a20bae0..7ec9c9c693 100644
--- a/academic/sword/sword.SlackBuild
+++ b/academic/sword/sword.SlackBuild
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sword
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.9.0}
BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -74,9 +74,6 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-#patch to fix pre-chapter text, required for xiphos. when sword tag>1.8.1
-#remove this patch as it will be included.
-patch -p0 -i $CWD/$PRGNAM.diff
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -85,11 +82,10 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
#now patch the automake stuff so it doesn't error on slackware's newer version
-#thanks to aur.archlinux.org for the information...
-#since update to 1.8.1 first patch has to be commented out. we will get a bunch of
-#warnings, but at least the library compiles
-#sed -i 's/AM_INIT_AUTOMAKE$/AM_INIT_AUTOMAKE\(\[subdir\-objects\]\)/g' configure.ac
sed -i 's/ftemplate-depth-25/ftemplate-depth\=125/g' configure.ac
+#patch to remove subdir-objects warnings
+sed -i 's/1.6/1.6 subdir-objects/g' lib/Makefile.am
+
./autogen.sh
#add workaround for compiling with more recent (>=61) versions of icu4c
CFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1" \
@@ -111,6 +107,8 @@ cp -a AUTHORS ChangeLog CODINGSTYLE COPYING INSTALL LICENSE NEWS README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+rm -f $PKG/usr/lib*/*.la
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh