summaryrefslogtreecommitdiffstats
path: root/desktop/wmtimer/wmtimer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/wmtimer/wmtimer.SlackBuild')
-rw-r--r--desktop/wmtimer/wmtimer.SlackBuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/desktop/wmtimer/wmtimer.SlackBuild b/desktop/wmtimer/wmtimer.SlackBuild
index aff16ab044..9bee25b083 100644
--- a/desktop/wmtimer/wmtimer.SlackBuild
+++ b/desktop/wmtimer/wmtimer.SlackBuild
@@ -25,7 +25,9 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Now maintained by B. Watson <yalhcru@gmail.com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
+
+# 20210909 bkw: BUILD=3, got bored and wrote a man page.
# 20160816 bkw:
# - took over maintenance
@@ -36,7 +38,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wmtimer
VERSION=${VERSION:-2.92}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,9 +50,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -83,21 +82,19 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
patch -p1 < $CWD/compilefix.diff
-sed -i -e "s,-O2,$SLKCFLAGS -fgnu89-inline," -e "s,-g ,," $PRGNAM/Makefile
+sed -i -e "s,-O2,$SLKCFLAGS -fcommon -fgnu89-inline," -e "s,-g ,," $PRGNAM/Makefile
make -C $PRGNAM
-mkdir -p $PKG/usr/bin
+mkdir -p $PKG/usr/bin $PKG/usr/man/man1
install -s -m0755 $PRGNAM/$PRGNAM $PKG/usr/bin
+gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Changelog COPYING CREDITS INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a Changelog COPYING CREDITS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install