summaryrefslogtreecommitdiffstats
path: root/development/jupyter-nbformat
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter-nbformat')
-rw-r--r--development/jupyter-nbformat/jupyter-nbformat.SlackBuild27
-rw-r--r--development/jupyter-nbformat/jupyter-nbformat.info12
2 files changed, 11 insertions, 28 deletions
diff --git a/development/jupyter-nbformat/jupyter-nbformat.SlackBuild b/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
index 313a5136ad..36a17de036 100644
--- a/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
+++ b/development/jupyter-nbformat/jupyter-nbformat.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for jupyter-nbformat
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter-nbformat
-VERSION=${VERSION:-5.1.3}
+VERSION=${VERSION:-5.10.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -52,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,15 +65,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/jupyter-nbformat/jupyter-nbformat.info b/development/jupyter-nbformat/jupyter-nbformat.info
index a401f73b97..295dbab3e8 100644
--- a/development/jupyter-nbformat/jupyter-nbformat.info
+++ b/development/jupyter-nbformat/jupyter-nbformat.info
@@ -1,10 +1,10 @@
PRGNAM="jupyter-nbformat"
-VERSION="5.1.3"
+VERSION="5.10.4"
HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbformat/nbformat-5.1.3.tar.gz"
-MD5SUM="70eb6150c6ea49aae042e2ecafb45378"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/n/nbformat/nbformat-5.10.4.tar.gz"
+MD5SUM="68dfea58a1236aa0518f1fec9c968473"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-jsonschema traitlets"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-jsonschema python3-fastjsonschema jupyter_core python3-hatch-nodejs-version"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"