summaryrefslogtreecommitdiffstats
path: root/graphics/photoqt/photoqt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/photoqt/photoqt.SlackBuild')
-rw-r--r--graphics/photoqt/photoqt.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/photoqt/photoqt.SlackBuild b/graphics/photoqt/photoqt.SlackBuild
index ccdeef72d2..111123fd8d 100644
--- a/graphics/photoqt/photoqt.SlackBuild
+++ b/graphics/photoqt/photoqt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for photoqt
-# Copyright 2013-2021 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2013-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=photoqt
-VERSION=${VERSION:-2.1.1}
+VERSION=${VERSION:-3.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -64,6 +64,7 @@ else
LIBDIRSUFFIX=""
fi
+if pkg-config --exists mpv; then MPV=ON; else MPV=OFF; fi
if pkg-config --exists exiv2; then EXIV2=ON; else EXIV2=OFF; fi
if pkg-config --exists GraphicsMagick; then GM=ON; else GM=OFF; fi
if pkg-config --exists libraw; then RAW=ON; else RAW=OFF; fi
@@ -88,18 +89,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i "s|exiv2lib|exiv2|" CMakeLists.txt
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DEXIV2=$EXIV2 \
- -DGM=$GM \
+ -DGRAPHICSMAGICK=$GM \
-DRAW=$RAW \
-DDEVIL=$DEVIL \
-DPOPPLER=$POPPLER \
-DFREEIMAGE=$FREEIMAGE \
+ -DVIDEO_MPV=$MPV \
+ -DCHROMECAST=NO \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG