summaryrefslogtreecommitdiffstats
path: root/libraries/FormEncode/FormEncode.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/FormEncode/FormEncode.SlackBuild')
-rw-r--r--libraries/FormEncode/FormEncode.SlackBuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/libraries/FormEncode/FormEncode.SlackBuild b/libraries/FormEncode/FormEncode.SlackBuild
index c25be9e8da..8b9e1924c8 100644
--- a/libraries/FormEncode/FormEncode.SlackBuild
+++ b/libraries/FormEncode/FormEncode.SlackBuild
@@ -22,25 +22,27 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220301 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - clean up doc dir. there's no "regen-docs" script in v1.26, and I
+# don't see a way to convert the docs/*.txt files to HTML. anyway
+# they're perfectly readable as-is, so just install them.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=FormEncode
VERSION=${VERSION:-1.2.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -61,16 +63,15 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
python setup.py install --root=$PKG
-./regen-docs || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a docs/_build/* $PKG/usr/doc/$PRGNAM-$VERSION/html || \
- cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf docs/_themes # 20220416 bkw: nothing useful here
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install