summaryrefslogtreecommitdiffstats
path: root/libraries/gdata/gdata.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/gdata/gdata.SlackBuild')
-rw-r--r--libraries/gdata/gdata.SlackBuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/libraries/gdata/gdata.SlackBuild b/libraries/gdata/gdata.SlackBuild
index 3d034f1fda..21edeb38b7 100644
--- a/libraries/gdata/gdata.SlackBuild
+++ b/libraries/gdata/gdata.SlackBuild
@@ -4,25 +4,26 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix doc permissions.
+# - remove useless INSTALL from doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gdata
VERSION=${VERSION:-2.0.18}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -43,15 +44,15 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
python setup.py install --root=$PKG --no-compile
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- INSTALL.txt PKG-INFO README.txt RELEASE_NOTES.txt \
+install -m0644 \
+ PKG-INFO README.txt RELEASE_NOTES.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild