summaryrefslogtreecommitdiffstats
path: root/multimedia/openshot
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/openshot')
-rw-r--r--multimedia/openshot/doinst.sh6
-rw-r--r--multimedia/openshot/openshot.SlackBuild16
-rw-r--r--multimedia/openshot/openshot.info10
3 files changed, 22 insertions, 10 deletions
diff --git a/multimedia/openshot/doinst.sh b/multimedia/openshot/doinst.sh
index 9a8ded3c60..9424ce43ff 100644
--- a/multimedia/openshot/doinst.sh
+++ b/multimedia/openshot/doinst.sh
@@ -5,3 +5,9 @@ fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/multimedia/openshot/openshot.SlackBuild b/multimedia/openshot/openshot.SlackBuild
index 8a0f3d1887..fc9a23f40b 100644
--- a/multimedia/openshot/openshot.SlackBuild
+++ b/multimedia/openshot/openshot.SlackBuild
@@ -3,7 +3,7 @@
# Copyright 2009, Jonathan Larsen (agentc0re), SLC, UT
# Contact Info: agentc0re 'AT' learnix 'DOT' net
#
-# Copyright 2016-2020 Christoph Willing, Brisbane Australia
+# Copyright 2016-2023 Christoph Willing, Brisbane Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -44,11 +44,15 @@
# From Oct 22nd, 2016-2020
# Maintenance & various version upgrades - Christoph Willing <chris.willing@linux.com>
+# 20220421 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add gtk-update-icon-cache to doinst.sh.
+# - stop writing outside of $TMP (except /root/.openshot_qt/).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=openshot
SRCNAM=openshot-qt
-VERSION=${VERSION:-2.5.1}
+VERSION=${VERSION:-3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -61,9 +65,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -103,6 +104,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# 20220421 bkw: setup.py doesn't need to call update-mime-database and
+# update-desktop-database; it spams the real /usr, and our doinst.sh
+# already does the job.
+sed -i '/^if ROOT and/,$d' setup.py
+
python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/multimedia/openshot/openshot.info b/multimedia/openshot/openshot.info
index 299ded68d3..61051444b8 100644
--- a/multimedia/openshot/openshot.info
+++ b/multimedia/openshot/openshot.info
@@ -1,10 +1,10 @@
PRGNAM="openshot"
-VERSION="2.5.1"
-HOMEPAGE="http://www.openshotvideo.com"
-DOWNLOAD="https://github.com/OpenShot/openshot-qt/archive/v2.5.1/openshot-qt-2.5.1.tar.gz"
-MD5SUM="e59bf56ac01aee5f43491aebebe479a8"
+VERSION="3.1.1"
+HOMEPAGE="http://www.openshot.org"
+DOWNLOAD="https://github.com/OpenShot/openshot-qt/archive/v3.1.1/openshot-qt-3.1.1.tar.gz"
+MD5SUM="e4d2c4b198ba4f4cc9bb00f54be34e4e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-pyzmq libopenshot httplib2 jack"
+REQUIRES="python3-pyzmq libopenshot python3-httplib2 jack"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"