summaryrefslogtreecommitdiffstats
path: root/office/python3-proselint
diff options
context:
space:
mode:
Diffstat (limited to 'office/python3-proselint')
-rw-r--r--office/python3-proselint/README25
-rw-r--r--office/python3-proselint/python3-proselint.SlackBuild100
-rw-r--r--office/python3-proselint/python3-proselint.info10
-rw-r--r--office/python3-proselint/slack-desc19
4 files changed, 154 insertions, 0 deletions
diff --git a/office/python3-proselint/README b/office/python3-proselint/README
new file mode 100644
index 0000000000..485ab690ee
--- /dev/null
+++ b/office/python3-proselint/README
@@ -0,0 +1,25 @@
+proselint is a turbocharget spellchecker
+
+proselint, a linter for English prose. A linter is a computer program
+that, akin to a spell checker, scans through a file and detects issues
+— like how a real lint roller helps you get unwanted lint off of your
+shirt.
+
+proselint places the world's greatest writers and editors by your
+side, where they whisper suggestions on how to improve your prose.
+You’ll be guided by advice inspired by Bryan Garner, David Foster
+Wallace, Chuck Palahniuk, Steve Pinker, Mary Norris, Mark Twain,
+Elmore Leonard, George Orwell, Matthew Butterick, William Strunk,
+Elwyn White, Philip Corbett, Ernest Gowers, and the editorial staff of
+the world’s finest literary magazines and newspapers, among others.
+Our goal is to aggregate knowledge about best practices in writing and
+to make that knowledge immediately accessible to all authors in the
+form of a linter for prose; all in a neat command-line utility that
+you can integrate into other tools, scripts, and workflows.
+
+Slackware users can access proselint in Emacs with minimal
+configuration, using flymake. (Or install flycheck from MELPA.)
+
+proselint should be extensible. If Slackware users find out that some
+plugins are advisable, feel free to contact the author to package some
+them.
diff --git a/office/python3-proselint/python3-proselint.SlackBuild b/office/python3-proselint/python3-proselint.SlackBuild
new file mode 100644
index 0000000000..f2471769b9
--- /dev/null
+++ b/office/python3-proselint/python3-proselint.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/bash
+
+# Slackware build script for python3-proselint
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-proselint
+TGZNAM=proselint
+VERSION=${VERSION:-0.13.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+ARCH=noarch
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+rm -rf $TGZNAM-$VERSION
+tar xvf $CWD/$TGZNAM-$VERSION.tar.gz
+cd $TGZNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE.md README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/python3-proselint/python3-proselint.info b/office/python3-proselint/python3-proselint.info
new file mode 100644
index 0000000000..dbd6bde13d
--- /dev/null
+++ b/office/python3-proselint/python3-proselint.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-proselint"
+VERSION="0.13.0"
+HOMEPAGE="https://proselint.com/"
+DOWNLOAD="https://files.pythonhosted.org/packages/a2/be/2c1bcc43d85b23fe97dae02efd3e39b27cd66cca4a9f9c70921718b74ac2/proselint-0.13.0.tar.gz"
+MD5SUM="1f09f9fc6959111d745083b240e8c928"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-proselint_2023-05-29@lockywolf.net"
diff --git a/office/python3-proselint/slack-desc b/office/python3-proselint/slack-desc
new file mode 100644
index 0000000000..1069be45fa
--- /dev/null
+++ b/office/python3-proselint/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-proselint: python3-proselint (a turbocharged stylistic checker spellchecker)
+python3-proselint:
+python3-proselint: proselint is a stylistic checker for English texts. It does no
+python3-proselint: punctuation or orthography checking, and works one step above them.
+python3-proselint:
+python3-proselint:
+python3-proselint:
+python3-proselint:
+python3-proselint:
+python3-proselint:
+python3-proselint: