summaryrefslogtreecommitdiffstats
path: root/python/boto
diff options
context:
space:
mode:
Diffstat (limited to 'python/boto')
-rw-r--r--python/boto/README8
-rw-r--r--python/boto/README.boto26
-rw-r--r--python/boto/boto.SlackBuild79
-rw-r--r--python/boto/boto.info10
-rw-r--r--python/boto/slack-desc19
5 files changed, 0 insertions, 142 deletions
diff --git a/python/boto/README b/python/boto/README
deleted file mode 100644
index 1153c28443..0000000000
--- a/python/boto/README
+++ /dev/null
@@ -1,8 +0,0 @@
-Boto is a Python package that provides interfaces to Amazon Web Services.
-
-The goal of boto is to support the full breadth and depth of Amazon Web
-Services. In addition, boto provides support for other public services such as
-Google Storage in addition to private cloud systems like Eucalyptus, OpenStack
-and Open Nebula.
-
-Optional dependencies: filechunkio, lxml and python-keyring
diff --git a/python/boto/README.boto b/python/boto/README.boto
deleted file mode 100644
index 8eb3041c15..0000000000
--- a/python/boto/README.boto
+++ /dev/null
@@ -1,26 +0,0 @@
-In order for boto to access an s3 resource it must be able to get the
-access key and secret key for an s3 account. The 3 ways that boto can
-obtain the keys are in the following order of precedence.
-
-1) Credentials passed into Connection class constructor
-2) Credentials specified by environment variables
-3) Credentials specified as options in a config file
-
-The easiest way for boto to read proper s3 credentials are from a
-global config file in /etc/boto.cfg or on a user basis in
-~/.boto.
-
-An example config file looks like the following:
-
-[Credentials]
-aws_access_key_id = <your access key>
-aws_secret_access_key = <your secret key>
-
-[Boto]
-debug = 0
-num_retries = 10
-
-proxy = myproxy.com
-proxy_port = 8080
-proxy_user = foo
-proxy_pass = bar
diff --git a/python/boto/boto.SlackBuild b/python/boto/boto.SlackBuild
deleted file mode 100644
index 28b2c6aed2..0000000000
--- a/python/boto/boto.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for boto
-
-# Copyright 2011-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=boto
-VERSION=${VERSION:-2.42.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst docs/*.pdf docs/*/*/v${VERSION}.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/README.$PRGNAM > $PKG/usr/doc/$PRGNAM-$VERSION/README.$PRGNAM
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/boto/boto.info b/python/boto/boto.info
deleted file mode 100644
index fa02eb073e..0000000000
--- a/python/boto/boto.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="boto"
-VERSION="2.42.0"
-HOMEPAGE="https://github.com/boto/boto"
-DOWNLOAD="https://github.com/boto/boto/archive/2.42.0/boto-2.42.0.tar.gz"
-MD5SUM="289a7902cf980b601db89c805ee1f405"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="paramiko rsa PyYAML simplejson"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/boto/slack-desc b/python/boto/slack-desc
deleted file mode 100644
index e693cb67e0..0000000000
--- a/python/boto/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-boto: boto (Interface to Amazon Web Services)
-boto:
-boto: Boto is a Python package that provides interfaces to Amazon Web
-boto: Services.
-boto:
-boto: Homepage: https://github.com/boto/boto
-boto:
-boto:
-boto:
-boto:
-boto: