summaryrefslogtreecommitdiffstats
path: root/system/bitrot/bitrot.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/bitrot/bitrot.SlackBuild')
-rw-r--r--system/bitrot/bitrot.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/system/bitrot/bitrot.SlackBuild b/system/bitrot/bitrot.SlackBuild
index 17c9a3cfd4..527810b281 100644
--- a/system/bitrot/bitrot.SlackBuild
+++ b/system/bitrot/bitrot.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for bitrot
+# Copyright © 2023 Logan Rathbone, Province of Ontario, Canada
# Copyright 2022 Brandon Pribula, BC Canada
-
# Copyright 2018 Donald Cooley South Haven, Indiana USA
# All rights reserved.
#
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bitrot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,7 +78,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true