summaryrefslogtreecommitdiffstats
path: root/system/bitrot
diff options
context:
space:
mode:
Diffstat (limited to 'system/bitrot')
-rw-r--r--system/bitrot/bitrot.SlackBuild12
-rw-r--r--system/bitrot/bitrot.info12
2 files changed, 14 insertions, 10 deletions
diff --git a/system/bitrot/bitrot.SlackBuild b/system/bitrot/bitrot.SlackBuild
index 17c9a3cfd4..314896543a 100644
--- a/system/bitrot/bitrot.SlackBuild
+++ b/system/bitrot/bitrot.SlackBuild
@@ -2,8 +2,8 @@
# Slackware build script for bitrot
+# Copyright © 2023-2024 Logan Rathbone, Province of Ontario, Canada
# Copyright 2022 Brandon Pribula, BC Canada
-
# Copyright 2018 Donald Cooley South Haven, Indiana USA
# All rights reserved.
#
@@ -27,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bitrot
-VERSION=${VERSION:-1.0.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,7 +78,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/system/bitrot/bitrot.info b/system/bitrot/bitrot.info
index f37f731d6a..6d47d37733 100644
--- a/system/bitrot/bitrot.info
+++ b/system/bitrot/bitrot.info
@@ -1,10 +1,10 @@
PRGNAM="bitrot"
-VERSION="1.0.0"
+VERSION="1.0.1"
HOMEPAGE="https://github.com/ambv/bitrot"
-DOWNLOAD="https://github.com/ambv/bitrot/archive/refs/tags/1.0.0/bitrot-1.0.0.tar.gz"
-MD5SUM="3bbed70851ce97b0736c062e20864235"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/bitrot/bitrot-1.0.1.tar.gz"
+MD5SUM="ab20267b7050bfb38f1d08a6c2e1fdf8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brandon Pribula"
-EMAIL="b.pribs11@gmail.com"
+REQUIRES="python3-setuptools-opt"
+MAINTAINER="Logan Rathbone"
+EMAIL="poprocks@gmail.com"