summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Grant Coady <bugsplatter@gmail.com>2010-05-11 20:00:36 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:00:36 +0200
commita590b0e41345a3ded9fc68efdbab8068fe66bf51 (patch)
tree01c27daecbf43afd4daafec3574e6aafb85eb7ff /graphics
parent9cb923ae531765033ab9aad9d45b8d7119900caf (diff)
downloadslackbuilds-a590b0e41345a3ded9fc68efdbab8068fe66bf51.tar.gz
slackbuilds-a590b0e41345a3ded9fc68efdbab8068fe66bf51.tar.xz
graphics/fly: Added to 12.0 repository
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fly/Makefile.diff13
-rw-r--r--graphics/fly/README8
-rw-r--r--graphics/fly/fly.SlackBuild49
-rw-r--r--graphics/fly/fly.info8
-rw-r--r--graphics/fly/slack-desc19
5 files changed, 97 insertions, 0 deletions
diff --git a/graphics/fly/Makefile.diff b/graphics/fly/Makefile.diff
new file mode 100644
index 0000000000..d7f1f507cf
--- /dev/null
+++ b/graphics/fly/Makefile.diff
@@ -0,0 +1,13 @@
+--- fly-2.0.0/Makefile.orig 2007-12-16 15:12:22.497364100 -0600
++++ fly-2.0.0/Makefile 2007-12-16 15:15:01.594430525 -0600
+@@ -9,8 +9,8 @@
+ INCDIRS = -I$(GD) -I/usr/local/web/include
+ CC = gcc
+
+-CFLAGS = -O -pedantic -Wall $(INCDIRS) $(LIBDIRS)
+-LIBS = -lgd -lm -lz -lttf -lpng -ljpeg #-lXpm
++CFLAGS += -pedantic -Wall $(INCDIRS) $(LIBDIRS)
++LIBS = -lgd -lm -lz -lpng -ljpeg #-lXpm
+
+ all: fly
+
diff --git a/graphics/fly/README b/graphics/fly/README
new file mode 100644
index 0000000000..9b542ee1b6
--- /dev/null
+++ b/graphics/fly/README
@@ -0,0 +1,8 @@
+fly - Create images from a text description file.
+
+fly is small program that takes a text input command file and creates an
+image file 'on the fly' to .gif, .jpg or .png format using the gd library.
+fly is suited for creating images from bash or awk scripts.
+
+This SlackBuild script patches the Makefile to remove an unused (obsolete)
+linking to the old ttf (before freetype) library so we get a clean compile.
diff --git a/graphics/fly/fly.SlackBuild b/graphics/fly/fly.SlackBuild
new file mode 100644
index 0000000000..f8735e08fe
--- /dev/null
+++ b/graphics/fly/fly.SlackBuild
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# Slackware build script for fly
+
+# Written by Grant Coady <http://bugsplatter.mine.nu> GPLv2
+
+PRGNAM=fly
+VERSION=2.0.0
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Patch the Makefile to support adding SLKCFLAGS and remove old -lttf linkage
+patch -p1 < $CWD/Makefile.diff
+
+CFLAGS="$SLKCFLAGS" make
+install -D -m 0755 fly $PKG/usr/bin/fly
+strip --strip-unneeded $PKG/usr/bin/fly
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/* examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/graphics/fly/fly.info b/graphics/fly/fly.info
new file mode 100644
index 0000000000..5df85650cb
--- /dev/null
+++ b/graphics/fly/fly.info
@@ -0,0 +1,8 @@
+PRGNAM="fly"
+VERSION="2.0.0"
+HOMEPAGE="http://martin.gleeson.com/fly/index.html"
+DOWNLOAD="http://martin.gleeson.com/fly/dist/fly-2.0.0.tar.gz"
+MD5SUM="b5efc8435a76ba2b2c592156ec5db4e2"
+MAINTAINER="Grant Coady"
+EMAIL="bugsplatter@gmail.com"
+APPROVED="rworkman"
diff --git a/graphics/fly/slack-desc b/graphics/fly/slack-desc
new file mode 100644
index 0000000000..12f625bd81
--- /dev/null
+++ b/graphics/fly/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+fly: fly (Create images from a text description file)
+fly:
+fly: fly is small program that takes a text input command file and
+fly: creates an image file 'on the fly' to .gif, .jpg or .png format
+fly: using the gd library. fly is suited to creating images from
+fly: bash or awk scripts.
+fly:
+fly: Homepage: http://martin.gleeson.com/fly/index.html
+fly:
+fly:
+fly: